[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Re: can't apt-get install

Le vendredi 01 septembre 2006 à 00:14 +0200, Michael Noisternig a
écrit :
> <snip>
> >> Eventually I figured the problem is that the packages apt-get hangs on 
> >> are those that are just not in the testing repository! On navigating the 
> >> web browser to the lib packages directory, I can find libglib2.0 and 
> >> libgtk2.0, but no 1.2 versions. Seems like there is some problem!? But 
> >> isn't apt-get supposed to get the dependencies right?
> > 
> > Yeah, that's why I reminded you to apt-get update, so that your list of
> > available packages really reflected what was on the server.
> > 
> > I've just downloaded them from
> > http://ftp.de.debian.org/debian/pool/main/g/gtk+1.2/libgtk1.2_1.2.10-18_i386.deb
> > and
> > http://ftp.de.debian.org/debian/pool/main/g/glib1.2/libglib1.2_1.2.10-10.1_i386.deb
> > 
> > Perhaps your mirror is screwed?
> Sorry, I was wrong. The mirror is ok. Just for some reason unknown to me 
> apt-get (and aptitude) doesn't manage to get certain packages. apt-get 
> (aptitude) update/clean/autoclean/dist-upgrade/check makes no difference.
> What now?

Now you've pin-pointed your problem: it is with APT, which fails to
download some packages. As far as I understand, the problem is
reproducible with the packages that are affected (if a package does not
install a first time, insisting won't help).

Before anything else, I would try a couple of different mirrors, perhaps
the problem really lies there.

If that fails, and if you can live with it, you'll have to download
those packages by hand and "dpkg -i" them. If you can't, I'd suggest you
reinstall your system, with the stable release this time, which should
work better. It's not that outdated, and you can get some newer versions
of prominent software from www.backports.org.

It's possible that there is a problem with your configuration, but it
may be a bug in APT. You should send a bug report against this package
with all information gathered so far, and be ready to test things if the
developers need more input. For such testing purposes, if you wipe-out
this installation and install sarge instead, you could setup a chroot
(but you may not have to). By the way, have you tried turning on
verbosity/debugging options? That would certainly help solving the
problem on the long run.

I can't help you much further, I hope you'll manage your problems and
get a nice Debian box soon! I also hope the bug you've hit, if it is
one, will be resolved in due time.

If you want more help from this list, I suggest you rename the topic to
something more specific, like "APT fails to download some packages".

Regards, Thibaut.

Reply to: