[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: GPG error on apt-get update



Chinook wrote:

> Joey Hess wrote:
>> Bernd Prager wrote:
>>> Hi,
>>>
>>> I'm getting a GPG error when I execute an apt-get update:
>>> ...
>>>
>>> But root has the required keys in the pubring:
> 
> I've been following this issue and also did:
> debian1:/home/leec# wget http://ftp-master.debian.org/ziyi_key_2005.asc
> -O - | sudo apt-key add -
> debian1:/home/leec# wget http://ftp-master.debian.org/ziyi_key_2006.asc
> -O - | sudo apt-key add -
> 
> The wgets were successful but didn't help the "Not Authenticated" issue.
> 
>> 
>> They have to be in apt's keyring, man apt-key.
>> 
> 
> So how do you get them there Joey?
> 
> That's the part I've missed in "Check the list for the last few days"
> Adam.

The two commands above that pipe to apt-key should do it.  They worked fine
here (I just installed the 2006 key).

Grasping at straws here...have you apt-get updated since then?  Do you have
any non-Debian repos in your sources.list?  For example, I have nerim.net
and a few others, but many of them also have signing keys, just like
Debian.  A few don't, but I just ignore the warnings on those.  Are you
running the latest version of apt?



Reply to: