[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: xserver-xfree86 and xserver-xorg problem



James Vahn wrote:

> cc wrote:
>> 'apt-get install xserver-xfree86 ' will install 'xserver-xorg'
>> instead of xserver-xfree86, whats the matter ?
>> 
>> i want to install xfree86, not xorg....
> 
> me too.. so i put this line in sources.list :
> 
>         deb http://snapshot.debian.net/archive pool xfree86
> 
> and all is well again. For now.

"For now" is right.  This is probably not such a good idea in the long
run.  If you are running etch or sid (which I assume you are, otherwise
you wouldn't need snapshot.debian.net to get XFree86) then you won't get
any security fixes for XFree86.  Better to add the following to
sources.list instead:

deb http://security.debian.org/ sarge/updates main contrib non-free

This way your XFree86 packages will at least get security fixes for the
lifetime of Sarge.  There was one just a week ago:
http://www.debian.org/security/2005/dsa-816

regards,

-- 
Kevin B. McCarty <kmccarty@princeton.edu>   Physics Department
WWW: http://www.princeton.edu/~kmccarty/    Princeton University
GPG: public key ID 4F83C751                 Princeton, NJ 08544



Reply to: