[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem with webmin-exports

Ok I solved this problem partly.
It seems that NFS exports is per filesystem, I exported /mnt, where my disks is mounted. I had to export each individual filesystem. This is common knowledge when dealing with NFS, I hadnt a clue.
The problem with webmin-exports still remains. It doesnt work.

On 9/16/05, Nils Erik Svangård <nilserik@gmail.com> wrote:
Ok I still have problems, I have tried some more things:
#cat /etc/exports

#ls -al /mnt
totalt 52
drwxr-xr-x   7 nisse nisse 4096 2005-04-07 15:20 .
drwxr-xr-x  23 root  root  4096 2005-07-23 13:57 ..
drwxr-xr-x  22 nisse nisse 4096 2005-08-31 01:23 Bryggan
drwxr-xr-x  13 nisse nisse 8192 2005-09-12 09:41 Massa
drwxr-xr-x  13 nisse nisse 4096 2005-09-12 10:08 Skogen
drwxr-xr-x  28 nisse nisse 4096 2005-07-05 23:43 Spriten
drwxr-xr-x  18 nisse nisse 8192 2005-09-12 10:33 Tallen
#ls -al /mnt/Spriten

When mounting the nfs dir from solaris, only the directories are show none of the contents, and no subdirs.

On 9/15/05, Nils Erik Svangård <nilserik@gmail.com > wrote:
I use unstable which I update everyday. I have big issues with NFS. I had it working around christmas, and I havent touched the config since then. Now it doesnt work.
I have used webmin to manage my exports.
The signs of trouble:
1. Just the directories are visable when i go to /net/mycompuer from Solaris.
2. Updating the config in webmin, saving, and trying to restart gives the following:

rpc.nfsd: no process killed
sh: /etc/init.d/netstd_nfs: No such file or directory
sh: /etc/init.d/netstd_nfs: No such file or directory

3. I manually stop nfs-common, nfs-kernel... ,nfs-user...
And start nfs-common and nfs-kernel-server which gives:
Something about sync and async which has changed from previous versions, assuming sync.
Only the directories are visable.

4. I do a nfs-kernel-server stop, and start the nfs-user-server. The directories are not visable, get a error message NFS gattr failed for .... (RPC: Authentication error).

5. I start both kernel and user server, the dirs are readable but no files are listed.

 Hide filesystem i set to no.

I have no idea to solve this. Does anyone have any suggestions?

(And by the way, debian rocks!)

Reply to: