[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: broken cups in sid



On Sat, May 29, 2004 at 06:43:00PM -0400, richard lyons wrote:
> On Saturday 29 May 2004 17:33, Micha Feigin wrote:
> > On Sat, May 29, 2004 at 03:01:42PM -0400, richard lyons wrote:
> 
> > > I dist-upgraded from sarge to sid abt. three days ago, and lost
> > > (amongst others) cups.  As far as I could understand, there was a
> > > conflict between two versions of libcupsys2. 
> > > [...] 
> > > So I removed 
> > > gnumeric and juggled a few versions in the foomatic-gimp-print /
> > > libcupsys2 / etc until aptitude said nothing was broken, and
> > > installed.  Magic! - cupsys was up and running, I could log onto
> > > localhost:631 and it all looked good.  But I cannot print or add
> > > a printer or do any admin function.  I get
> > > "client-error-bad-request" or "client-error-gone" for every
> > > action.
> [...]
> > I had a bit of an head ache solving the dependencies as there was a
> > new tls version or something like that some packages depended on
> > causes cross reference problems.
> >
> > Once I solved this properly (making sure I still have
> > gnome-cups-manager) everything was fine.
> 
> Micha, what do you mean by 'solved this properly'?  I thought I had, 
> for a moment.  No packages are shown as broken by aptitude (which may 
> be a less-than-difinitive test).  But it doesn't work and I don't 
> understand what kind of not-working this is.
> 

I mean I got the dependencies resolved to a point that I could keep the
programs I wanted. See if you can get gnome-cups-manager running and
try adding a printer through it. Otherwise where does adding a printer
fail?

Here is a list of the cups related packages I have installed if it
helps (I am not sure all are needed but I didn't feel like trying to
figure which to throw out):

i   cupsomatic-ppd                  - linuxprinting.org printer support - transi
i A cupsys                          - Common UNIX Printing System(tm) - server  
i A cupsys-bsd                      - Common UNIX Printing System(tm) - BSD comm
i A cupsys-client                   - Common UNIX Printing System(tm) - client p
i   cupsys-driver-gimpprint-data    - Gimp-Print printer drivers for CUPS       
i   cupsys-pt                       - Tool for viewing/managing print jobs under
i A foomatic-db                     - linuxprinting.org printer support - databa
i A foomatic-db-engine              - linuxprinting.org printer support - progra
i   foomatic-db-gimp-print          - linuxprinting.org printer support - databa
i   foomatic-db-hpijs               - linuxprinting.org printer support - databa
i   foomatic-filters                - linuxprinting.org printer support - filter
i   foomatic-filters-ppds           - linuxprinting.org printer support - prebui
i   gnome-cups-manager              - CUPS printer admin tool for GNOME         
i A libcupsimage2                   - Common UNIX Printing System(tm) - image li
i A libcupsys2-gnutls10             - Common UNIX Printing System(tm) - libs    
i   libgnomecups1.0-1               - GNOME library for CUPS interaction        
i   libgnomecupsui1.0-1             - UI extensions to libgnomecups      

> -- 
> richard
> 
> 
> -- 
> To UNSUBSCRIBE, email to debian-user-REQUEST@lists.debian.org 
> with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
> 
>  
>  +++++++++++++++++++++++++++++++++++++++++++
>  This Mail Was Scanned By Mail-seCure System
>  at the Tel-Aviv University CC.
> 



Reply to: