[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: need advice Iptables/2.4.25



On Sat, 2004-04-03 at 03:55, Thierry wrote:
> Hi,
> I have got a little problem with iptables 1.2.9-6 running on laptop
> debian SID/kernel 2.4.25 ...
> 
> /lib/modules/2.4.25/kernel/net/ipv4/netfilter/ip_tables.o:
> /lib/modules/2.4.25/k
> ernel/net/ipv4/netfilter/ip_tables.o: unresolved symbol
> nf_unregister_sockopt
> /lib/modules/2.4.25/kernel/net/ipv4/netfilter/ip_tables.o:
> /lib/modules/2.4.25/k
> ernel/net/ipv4/netfilter/ip_tables.o: unresolved symbol
> nf_register_sockopt
> /lib/modules/2.4.25/kernel/net/ipv4/netfilter/ip_tables.o: insmod
> /lib/modules/2
> .4.25/kernel/net/ipv4/netfilter/ip_tables.o failed
> /lib/modules/2.4.25/kernel/net/ipv4/netfilter/ip_tables.o: insmod
> ip_tables fail
> ed
> iptables v1.2.9: can't initialize iptables table `filter': iptables who?
> (do you
>  need to insmod?)
>  Perhaps iptables or your kernel needs to be upgraded.
>  /lib/modules/2.4.25/kernel/net/ipv4/netfilter/ip_tables.o:
>  /lib/modules/2.4.25/k
>  ernel/net/ipv4/netfilter/ip_tables.o: unresolved symbol
>  nf_unregister_sockopt
>  /lib/modules/2.4.25/kernel/net/ipv4/netfilter/ip_tables.o:
>  /lib/modules/2.4.25/k
>  ernel/net/ipv4/netfilter/ip_tables.o: unresolved symbol
>  nf_register_sockopt
>  /lib/modules/2.4.25/kernel/net/ipv4/netfilter/ip_tables.o: insmod
>  /lib/modules/2
>  .4.25/kernel/net/ipv4/netfilter/ip_tables.o failed
>  /lib/modules/2.4.25/kernel/net/ipv4/netfilter/ip_tables.o: insmod
>  ip_tables fail
>  ed
>  iptables v1.2.9: can't initialize iptables table `filter': iptables
>  who? (do you
>   need to insmod?)
>   Perhaps iptables or your kernel needs to be upgraded.
>   /lib/modules/2.4.25/kernel/net/ipv4/netfilter/ip_tables.o:
>   /lib/modules/2.4.25/k
>   ernel/net/ipv4/netfilter/ip_tables.o: unresolved symbol
>   nf_unregister_sockopt
>   /lib/modules/2.4.25/kernel/net/ipv4/netfilter/ip_tables.o:
>   /lib/modules/2.4.25/k
>   ernel/net/ipv4/netfilter/ip_tables.o: unresolved symbol
>   nf_register_sockopt
>   /lib/modules/2.4.25/kernel/net/ipv4/netfilter/ip_tables.o: insmod
>   /lib/modules/2
>   .4.25/kernel/net/ipv4/netfilter/ip_tables.o failed
>   /lib/modules/2.4.25/kernel/net/ipv4/netfilter/ip_tables.o: insmod
>   ip_tables fail
>   ed
>   iptables v1.2.9: can't initialize iptables table `filter': iptables
>   who? (do you
>    need to insmod?)
>    Perhaps iptables or your kernel needs to be upgraded.
>    cat: /proc/net/ip_tables_names: No such file or directory
>    /lib/modules/2.4.25/kernel/net/ipv4/netfilter/ip_conntrack.o:
>    /lib/modules/2.4.2
>    5/kernel/net/ipv4/netfilter/ip_conntrack.o: unresolved symbol
>    nf_unregister_hook
>    /lib/modules/2.4.25/kernel/net/ipv4/netfilter/ip_conntrack.o:
>    /lib/modules/2.4.2
>    5/kernel/net/ipv4/netfilter/ip_conntrack.o: unresolved symbol
>    nf_unregister_sock
>    opt
>    /lib/modules/2.4.25/kernel/net/ipv4/netfilter/ip_conntrack.o:
>    /lib/modules/2.4.2
>    5/kernel/net/ipv4/netfilter/ip_conntrack.o: unresolved symbol
>    ip_ct_attach
>    /lib/modules/2.4.25/kernel/net/ipv4/netfilter/ip_conntrack.o:
>    /lib/modules/2.4.2
>    5/kernel/net/ipv4/netfilter/ip_conntrack.o: unresolved symbol
>    nf_register_hook
>    /lib/modules/2.4.25/kernel/net/ipv4/netfilter/ip_conntrack.o:
>    /lib/modules/2.4.2
>    5/kernel/net/ipv4/netfilter/ip_conntrack.o: unresolved symbol
>    nf_register_sockop
>    t
>    /lib/modules/2.4.25/kernel/net/ipv4/netfilter/ip_conntrack.o: insmod
>    /lib/module
>    s/2.4.25/kernel/net/ipv4/netfilter/ip_conntrack.o failed
>    /lib/modules/2.4.25/kernel/net/ipv4/netfilter/ip_conntrack.o: insmod
>    ip_conntrac
>    k_ftp failed
> 

I'm assuming that you rolled your own kernel, since the kernel-release
name is just the plain version number. 

Did you compile "network packet filtering" support into the kernel, or
as a module (thats under "networking options" in menuconfig)? 

Verify that the iptables kernel module exists in that path:

ls /lib/modules/`uname -r`/kernel/net/ipv4/netfilter/ip_tables.o

Have you rebooted since you compiled/installed your kernel+modules?

>    Is that kernel bug or me or iptables ?
>    Should i send a bug report ?
> 

If you've done nothing more than attempt to run iptables, then its a bit
soon to submit a bug report. 

Just a tip: Its generally a good idea to provide a list of the steps you
have already taken in your investigation of the problem. Otherwise, it
seems as if you are just asking others to do all the work of problem
solving. Most likely you've already tried a bunch of things, but we cant
tell from the info you provided :)

hope that helps

-davidc




Reply to: