[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: A Newbie LVM Question



On Thursday 04 March 2004 10:38 am, stan wrote:
> On Thu, Mar 04, 2004 at 05:09:02PM +0200, Alexei Chetroi wrote:
> > On Thu, Mar 04, 2004 at 08:13:18AM -0500, stan wrote:
> > > Date: Thu, 4 Mar 2004 08:13:18 -0500
> > > From: stan <stanb@panix.com>
> > > To: debian-user@lists.debian.org
> > > Subject: Re: A Newbie LVM Question
> > >
> > > On Wed, Mar 03, 2004 at 02:42:30PM -0500, stan wrote:
> > > > On Wed, Mar 03, 2004 at 09:37:06AM +0100, Erich Waelde wrote:
> > > > Content-Description: message body text
> > >
> > > I made a little more progress on this last night. I was able to
> > > actually create a working lvm, and format it as XFS (I do think I left
> > > some rements of a bad atempt laying aroud BTW, is it safe to just
> > > rmmive these traces?).
> > >
> > >
> > > In any case, when I rebooted that machine the new lvm parition did not
> > > mount (yes I put it in /etc/fstab)/ Atempts to mount it by had result
> > > in a message about it not being "active".
> >
> >  Do you have script /etc/init.d/lvm ? 1st you must run vgscan to scan
> >  volume groups and after that vgchange -a y
>
> I do, but I don'r seem to have any links to it from the various /etc/rc.d
> directories.
>
> How can I create these (In a Debian sort of way?). I know I can create them
> by hand, but thre must be a more "Debian" way fo doing it, right?
>

You need to have lvm10 and lvm-common installed and if using a standard debian 
kernel, need to have lvm-mod module running.  I am pretty sure that 
installing lvm10 and/or lvm-common should have set up the /etc/init.d/lvm for 
you.

John



Reply to: