[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: help apt upgrade issue

developer@wexwarez.com wrote:

> I am running a debian woody mixing stable and testing and very random few
> unstable packages with the 2.4.24 kernel.  I just did an apt-get -u
> dist-upgrade and there was a couple upgrades none seemed very significant
> but it bombed out at the end. Now it bombs out everytime i do an upgrade
> and a couple things seem broken like my openoffice stopped working.  Seems
> to be a conflict with the xlibmesa3 upgrade and my existing libGLU.so.1.3
> package?
> Here is the output:
> S# apt-get -u dist-upgrade
> Reading Package Lists... Done
> Building Dependency Tree... Done
> Calculating Upgrade... Done
> The following packages have been kept back:
>   scrollkeeper
> The following packages will be upgraded:
>   xlibmesa3
> 1 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
> Need to get 0B/3423kB of archives.
> After unpacking 0B of additional disk space will be used.
> Do you want to continue? [Y/n]
> (Reading database ... 61643 files and directories currently installed.)
> Preparing to replace xlibmesa3 4.1.0-16woody1 (using
> .../xlibmesa3_4.1.0-16woody3_i386.deb) ...
> Unpacking replacement xlibmesa3 ...
> dpkg: error processing
> /var/cache/apt/archives/xlibmesa3_4.1.0-16woody3_i386.deb (--unpack):
>  trying to overwrite `/usr/X11R6/lib/libGLU.so.1.3', which is also in
> package xlibmesa3-glu
> dpkg-deb: subprocess paste killed by signal (Broken pipe)
> Errors were encountered while processing:
>  /var/cache/apt/archives/xlibmesa3_4.1.0-16woody3_i386.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)
> -thanks ryan
it sounds like a conflict with xlibmesa3-glu 4.2.1-12.1 (testing), isn't it.

this is resolved upgrading xlibmesa3 to 4.2.1-12.1 and installing
xlibmesa3-gl 4.2.1-12.1 from testing


Reply to: