[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sound problems in Sid



Curt Howland wrote:

Hi. Well, it worked under Knoppix, so I'm sure it's just me.
<snip>

I've just finished wiping and reinstalling Sid on a Vaio PCG-GRT170, which has worked before but got messed up with a Xwindows upgrade last week. Everything has come back except sound. mpg123 and xmms just hang until killed, and the following error is seen in dmesg:

  i810_audio: drain_dac, dma timeout?

I've set the permissions on /dev/dsp and /dev/audio to 777, just to make sure that wouldn't be the problem. Also...

lsmod:
i810_audio             24764   0
ac97_codec             13716   0  [i810_audio]
soundcore               3940   2  [i810_audio]

lspci:
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] Sound Controller (rev a0)

KDE InfoCenter shows only one DMA-Channel, "4 cascade". When I cat sound.au > /dev/audio, I get a screech, so it seems that's completely out of time sync.

The Sound-HowTo talked about kernel modules, which doesn't seem to be the problem here.

Any suggestions? I expect it's a permissions problem that I just don't see, or the DMA that I just don't know how to make work.

1]
Boot off the Knoppix CDs; check what modules are installed. Install those modules once you're back in sid.

2]
Make sure your user is in the "audio" group.

--
Kent



Reply to: