[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: HP printer saga

J. Zidar wrote:
--SNIP-- <

The package hpijs is already installed.
Cups packages installed: cupsys(1.1.14-5), cupsys-bsd(1.1.14-5), cupsys-client(1.1.14-5), cupsys-pstoraster(1.1.14-5), qtcups(2.0-4), hpijs (1.3.1-1.1), a2ps(4.13b-16), apsfilter(7.2.2-3), gcc(3.3), glibc(didn't find).

The ppd file mentioned "foomatic-rip". When I searched the packages with apt I've found foomatic-bin, but it won't install because of some unmet dependencies (in such cases I usually install packages from unstable).

I'm using stable with some packages from unstable.

C YA and thank you so far,
Jernej Zidar

Mixing "stable" with "unstable" leads to a dependency nightmare, in my experience. This is especially true during major upgrades to gcc and glibc like what is going on right now. I would suggest sticking with one or the other, and not mixing them. I have frequent dependency-related problems here mixing "testing" and "unstable".

I have a few suggestions based on the above info:

1. The "apsfilter" package is unnecessary with CUPS. I doubt it is a direct cause of your problem, but it might be causing some dependency problems. I suggest you purge it.

2. There are two different "foomatic-bin" packages. The one in "testing"/"ustable" is actually a dummy package that installs a set of other packages....significantly the "foomatic-filters" package, which contains the "foomatic-rip" program! This program doesn't exist in the "stable" version of foomtic-bin or in any other package. Thus, your ppd driver seems to be requiring that you install the "unstable" or "testing" version of foomatic-bin! I would suggest you do this and resolve any depencency problems ablong the way. I know I have to have the foomatic-bin package installed here for my printer to work with the ppd from linuxprinting.org.

3. Alternatively, I have had luck with the generic "hp-900 series" driver from the "cupsys-driver-gimpprint" package on my HP 960C printer. I note that this package has a driver for the "hp-600 series" printers, which might work ok for you.


-Don Spoon-

Reply to: