[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Trouble with Mozilla Java plugin

On Sunday 01 June 2003 07:15, Roberto Sanchez wrote:
>  --- Nathan Poznick <poznick@conwaycorp.net> escribió:
> > That is almost undoubtedly due to that version of Java being
> > compiled with gcc 2.95, and mozilla being compiled with gcc 3.x. 
> > The dates on the files from that mirror are quite old... Try using:
> ftp://ftp.tux.org/pub/java/JDK-1.4.1/i386/01/j2re-1.4.1-01-linux-i586
> > That is a version compiled with gcc 3.2, and it works for me
> > (whereas the version from that apt archive doesn't).

> That sure did the trick (I didn't realize the gcc version had an
> impact). Thanks.

The compiler version is always important (due to the nature of C).
For example Mozilla 1.4 can be compiled with gcc on windows, but no 
plugin would then work with it, because all the plugins have been 
compiled with the Microsoft compiler.

Just my $0.02


/* There is SCO owned IP all over the Linux kernel. SCO will hunt them.
Free software infidels are liars. We will kill them all, and roast their
stomach in hell. Our estimates show that all slashodot viewers will die.
 --Mohammad Al-Sahhaf SCO Sopkesman, Former Iraqi information minister*/

Aryan Ameri

Reply to: