[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Broken packages trying to install cupsys



I suppose this is because I'm running a mix of testing/unstable.

Trying to install cupsys and I get an error with gs-esp package.  So I
install and it still doesn't fix the problem.  Trying to then install
cupsys I get:

  Sorry, but the following packages have unmet dependencies:
    cupsys: Depends: gs-esp but it is not going to be installed
  E: Sorry, broken packages

Hum, but gs-esp is installed.

ii  gs-esp              7.05.4-1            The Ghostscript Postscript interpreter - ESP version

That's the version of gs-esp in testing.  Cupsys in testing points to
that.

What I really need help with is understanding how to find out exactly
what's going on.

Looking at the cupsys package:

  # apt-cache showpkg cupsys

Shows a Dependencies: section that for version 1.1.15-4 (the
testing version) that includes:

  gs-esp (0 (null))

So I'm not sure what that means.

Clearly apt-get is seeing a problem.  Sure would be nice if apt spelled it
out instead of just saying "it is not going to be installed".

How do I resolve this?  No, what do I need to do to understand how to
resolve problems like this?

Thanks,


# apt-get install gs-esp
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
  libcupsys2 
The following NEW packages will be installed:
  gs-esp libcupsys2 
0 packages upgraded, 2 newly installed, 0 to remove and 0  not upgraded.
Need to get 2698kB of archives. After unpacking 9085kB will be used.
Do you want to continue? [Y/n] y
Get:1 http://http.us.debian.org testing/main libcupsys2 1.1.15-4 [117kB]
Get:2 http://http.us.debian.org testing/main gs-esp 7.05.4-1 [2581kB]
Fetched 2698kB in 33s (81.2kB/s)                                                                   
Selecting previously deselected package libcupsys2.
(Reading database ... 41664 files and directories currently installed.)
Unpacking libcupsys2 (from .../libcupsys2_1.1.15-4_i386.deb) ...
Selecting previously deselected package gs-esp.
Unpacking gs-esp (from .../gs-esp_7.05.4-1_i386.deb) ...
Setting up libcupsys2 (1.1.15-4) ...

Setting up gs-esp (7.05.4-1) ...

bumby:/etc/X11# apt-get install cupsys cupsys-bsd cupsys-pstoraster
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

Sorry, but the following packages have unmet dependencies:
  cupsys: Depends: gs-esp but it is not going to be installed
E: Sorry, broken packages




-- 
Bill Moseley moseley@hank.org



Reply to: