[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

lm-sensors



Hi all,

i just wanted to use lm-sensors to check voltages, temperatures ..

1  I installed lm-sensors, lm-sensors-source and i2c-source
2  compiled the modules
3  Did a lm-sensors detect

but no LMXX was found. Only

eeprom-i2c-1-50
Adapter: I2C Voodoo3/Banshee adapter
Algorithm: Bit-shift algorithm

eeprom-i2c-2-50
Adapter: DDC Voodoo3/Banshee adapter
Algorithm: Bit-shift algorithm

eeprom-i2c-2-51
Adapter: DDC Voodoo3/Banshee adapter
Algorithm: Bit-shift algorithm


My relevant kernel opts (2.4.20) are:


# I2C support
CONFIG_I2C=m
CONFIG_I2C_ALGOBIT=m
CONFIG_I2C_PHILIPSPAR=m
CONFIG_I2C_ELV=m
CONFIG_I2C_VELLEMAN=m
CONFIG_I2C_ALGOPCF=m
CONFIG_I2C_ELEKTOR=m
CONFIG_I2C_CHARDEV=m
CONFIG_I2C_PROC=m
CONFIG_I2C_PARPORT=m


CONFIG_ISA=y
CONFIG_EISA=y
CONFIG_ISAPNP=m
# CONFIG_BLK_DEV_ISAPNP is not set
# CONFIG_NET_ISA is not set

My chipset:

00:00.0 Host bridge: Acer Laboratories Inc. [ALi] M1541 (rev 04)
00:01.0 PCI bridge: Acer Laboratories Inc. [ALi] M1541 PCI to AGP Controller (rev 04)
00:02.0 USB Controller: Acer Laboratories Inc. [ALi] USB 1.1 Controller (rev 03)
00:07.0 ISA bridge: Acer Laboratories Inc. [ALi] M1533 PCI to ISA Bridge [Aladdin IV] (rev c3)
00:09.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C (rev 10)
00:0a.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 08)
00:0f.0 IDE interface: Acer Laboratories Inc. [ALi] M5229 IDE (rev c2)
01:00.0 VGA compatible controller: 3Dfx Interactive, Inc. Voodoo 3 (rev 01)

modprobe i2c-ali15x3 tells:

i2c-ali15x3.o version 2.6.4 (20020719)
i2c-ali15x3.o: Error: Can't detect ali15x3!
i2c-ali15x3.o: ALI15X3 not detected, module not inserted.
/lib/modules/2.4.20/misc/i2c-ali15x3.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
      You may find more information in syslog or the output from dmesg
/lib/modules/2.4.20/misc/i2c-ali15x3.o: insmod /lib/modules/2.4.20/misc/i2c-ali15x3.o failed
/lib/modules/2.4.20/misc/i2c-ali15x3.o: insmod i2c-ali15x3 failed


What did I wrong?


Thanks in advance

Elimar

-- 
  Do you smell something burning or ist it me?

Attachment: pgpI_82dXM4o_.pgp
Description: PGP signature


Reply to: