[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Actiontec Wireless USB Adapter Problem



I have struggled with linux-wlan-ng, pcmcia-cs and instructions from Actiontec tech support and from netmagenetworks.com with partial success. That is ifconfig -a reports wlan0, /proc/bus/usb/drivers includes prism2_usb and ifup wlan0 reports interface wlan0 already configured. But something is wrong. I hope the attached excerpts from kern.log are a clue which will enable someone to help me.
Dec 10 17:07:15 Dragon kernel: NET4: Linux TCP/IP 1.0 for NET4.0
Dec 10 17:07:15 Dragon kernel: IP Protocols: ICMP, UDP, TCP
Dec 10 17:07:15 Dragon kernel: IP: routing cache hash table of 512 buckets, 4Kbytes
Dec 10 17:07:15 Dragon kernel: TCP: Hash tables configured (established 8192 bind 8192)
Dec 10 17:07:15 Dragon kernel: NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
Dec 10 17:07:15 Dragon kernel: ds: no socket drivers loaded!
Dec 10 17:07:15 Dragon kernel: hub.c: USB new device connect on bus1/2, assigned device number 3
Dec 10 17:07:15 Dragon kernel: usb.c: kmalloc IF c12474a0, numif 1
Dec 10 17:07:15 Dragon kernel: usb.c: new device strings: Mfr=0, Product=0, SerialNumber=1
Dec 10 17:07:15 Dragon kernel: usb.c: USB device number 3 default language ID 0x409
Dec 10 17:07:15 Dragon kernel: SerialNumber: 111111111111
Dec 10 17:07:15 Dragon kernel: usb.c: unhandled interfaces on device
Dec 10 17:07:15 Dragon kernel: usb.c: USB device 3 (vend/prod 0x1668/0x421) is not claimed by any active driver.
Dec 10 17:07:15 Dragon kernel: usb.c: registered new driver prism2_usb
Dec 10 17:07:15 Dragon kernel: usb.c: prism2_usb driver claimed interface c12474a0
Dec 10 17:07:15 Dragon kernel: hfa384x_docmd: hfa384x_docmd:ctlx failure=REQ_TIMEOUT
Dec 10 17:07:15 Dragon kernel: hfa384x_drvr_start: hfa384x_drvr_startcmd_initialize() failed, result=-5
Dec 10 17:07:15 Dragon kernel: prism2sta_ifstate: hfa384x_drvr_start() failed,result=-5
Dec 10 17:07:15 Dragon kernel: hfa384x_usbin_callback: hfa384x_usbin_callback:Fatal, failed to resubmit rx_urb. error=-12

Reply to: