[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Package conflicts



Kovacs Istvan wrote:
Hi,

I would like to install the Zorp firewall
(http://www.balabit.hu/en/news/) on Woody. The packages provided by the
manufacturer require libglib1.3 and python-base, which are not
available on woody. Instead of libglib1.3, we have libglib2.0-data
(replacing libglib1.3) and python1.5 or python replacing pyhon-base.

I tried to create a package using equivs that requires the packages
python and libglib2.0-data and provides python-base and libglib1.3.
However, I'm not able to install that package, as it requires python
and provides python-base, and python conflicts with python-base. I have
never used equivs before, I just read about it as a way to resolve
dependency problems. I gave it a try, but I see that the reported
conflict is reasonable.

Previously, I installed Zorp using dpkg --force-depends, but that
resulted in apt complaints whenever I tried to use apt-get, so I had to
uninstall it.

Please let me know what the cleanest way to resolve the dependency
problem is. Of course I could build Zorp from source, but it would be
nice to take a more Debian road :-)

TIA,
Kofa


unar the deb[ar xvf zope.deb], untar the control.tar.gz, edit the control file removing the depends line(or /fix/), re-tar/gzip the control tar, re-ar the deb.




Reply to: