[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: Apache (PHP not working)

Hash: SHA1

If you compile your kernel yourself, make sure you choose your ethernet card in the kernel configuration as a module, then add "8139" to /etc/modules.

If you're just installing a precompiled kernel (from a package or something) just add the modules name "8139" to /etc/modules

edit your /etc/apache/httpd.conf and uncomment:
    AddType application/x-httpd-php .php 
    AddType application/x-httpd-php-source .phps

Vince Hillier

- -----Original Message-----
From: Michelle Storm [mailto:jade@ursine.dyndns.org] 
Sent: Wednesday, November 13, 2002 3:32 AM
To: Debian User List
Subject: Apache (PHP not working)

A little background.

jade@dragon:~$ uname -a
Linux dragon.ursine.dyndns.org 2.4.18-bf2.4 #1 Son Apr 14 09:53:28 CEST 2002 i686 unknown unknown GNU/Linux

**I would be using the newest kernel: 2.4.19-k7, except that I don't
know how to install a module to run my network card which uses 8139

Mozilla 1.1

I am using the latest of everything. including the unstable stuff.
right now my problem is with PHP.

I will attach a .tgz file with my httpd.conf and mime.types. (if there's
any other info you need. just tell me what (and how to get it)).

Before my computer crashed the LAST time. I had everything working.
Now I can't get php to work. I get the following error.

- ------------------------------------------------------------------------
You have chosen to download a file of type: application/x-httpd/php from

What should Mozilla do with this file?
- ------------------------------------------------------------------------

**I also try: http://localhost/ with the same result**

Last time all I had to do was fix the mime.types
this time they are correct (that I can tell)

I've done everything I can think of. (I was using apache2, found out
that php doesn't work with apache2 yet.. so installed apache again.

Then I removed everything related to apache and php
then I installed apache and php

it still gives me the exact error above.

My php files work on roomates apache and as far as I can tell.. mine is
setup nearly identical to his. So I don't know what's wrong.

1) I have used /etc/init.d/apache restart (stop, start)
2) I have tried /etc/init.d/apachectl restart (stop, start)
3) I have restarted my computer completely
4) removed apache and php packages
5) reinstalled apache and php packages
6) retried steps 1 - 3.

Still not working. So now I'm asking for any help I can get. This has
stumped me. And my roommate refuses to help.

- -- 
Michelle Alexia "Jade" Storm
Dragon Impersonating a Human and failing.

P.S. Attaching the following files just because they are related to php
and or Apache:

  "jades.apache-files.tgz" which contains: /etc/apache
  "jades.php4-files.tgz" which contains: /etc/php4
  "jades.phpmyadmin.tgz" which contains: /etc/phpmyadmin
  "jades.phppgadmin.tgz" which contains: /etc/phppgadmin

Version: PGP 8.0 (Build 349) Beta


Reply to: