[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: php4_4.0.3pl1-0potato1.deb install problem

"Haisam K. Ido" <haisam@ido.org> wrote:
>I've tried to install: php4_4.0.3pl1-0potato1.deb  
>and I get this error:
>dpkg: dependency problems prevent configuration of php4:
> php4 depends on apache-common (<<; however:
>  Version of apache-common on system is 1.3.12-1.
>dpkg: error processing php4 (--configure):
> dependency problems - leaving unconfigured
>Errors were encountered while processing:
> php4

Evidently you've upgraded to a newer version of apache than the one in
stable (1.3.9-13.1), so you'll need to find a comparable version of php4
to go with it. If you're upgrading apache to unstable (which
incidentally now has 1.3.14-2.1), then why not get php4 from there as

>Now this webpage http://packages.debian.org/stable/web/php4.html says
>apache-common (>= 1.3.9) 
>    Support files for all Apache webservers 
>apache-common (<< 
>    Support files for all Apache webservers
>Is'nt this a contradiction?

No, it means it depends on some version of apache-common between 1.3.9
(inclusive) and, such as 1.3.9-13.1. (Debian policy describes
how version numbers are compared.)

Colin Watson                                     [cjw44@flatline.org.uk]

Reply to: