[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [OFFTOPIC] BIOS Password defeat SOLVED!

Hello there,

Success in defeating the password! It was not that easy:
Many of you wrote, that I should pull out the CMOS-battery. So I looked
for one, but there was nothing on that board, which looked like a battery. 
So I copied the little program from Miroslav, which corrupts the checksum
of the CMOS to my Harddisk, unplugged it and plugged it into this
motherboard. But unfortunately the system even had a boot password on it.
So no way. 
But there was an IC on the board, that was a little larger than the
others, so I thougt, it might perhaps contain a battery. It was labelled:
benchmarq bq3287AMT. So I did a little search on the web about this, and
It is a RTC unit with builtin CMOS and battery. (For further information:
I found some additional information at
It says, that you should shortcut pin 12 and pin 21 with power off to
clear CMOS.
Unfortunately, the socket had pin 21 removed, so I could make no
connection. So I pulled the IC out and shortcutted them. When I booted
Enter Password:
So I thought, might need a longer time to clear CMOS. Left it standing
connected. No way, I booted: Enter password:
So I made a little connector out of a piece of aluminum foil and put it
into the empty pin 21 connector of the IC-socket, put the IC in and
connected via this connector. No way.
Last chance was to use brute force. So I left the pins connected and put
the computer ON. And guess what:
It worked. It said:
CMOS-battery low, replace and run Setup.
So I removed the connector again.
On the next boot it said:
CMOS-checksum corrupted, run Setup
So I ran it, and from now on everything worked fine.
I will contact the maintainer of the webpage mentioned above, that it
doesn't work with power off, and that the power should be on.
Long mail, but I hope it helps, that if anybody ever encounters such a
chip on his board he or she doesn't have to fight such a hard struggle.
P.S.: Thanks for all the replies, although none of them did the trick, I
at least got some ideas on where to start.

> I <reuter@Uni-Hohenheim.DE> wrote:
> I found a pretty nice 486 PCI-motherboard in the bulk waste last week,
> which I would like to use as secondary computer with debian. The board is
> working, but unfortunately, it was setup in a way that you can only boot
> from harddisk, and shadow RAM was enabled. So I tried to change the
> settings, but the preliminary user has installed a Setup-Password, so that
> I can't access the BIOS. I know, that there are ways to get around this,
> but I don't know how to do it in this special case. 
> So does anybody know where to find the necessary information? Is there a
> tool for Linux or DOS to access and change BIOS-settings (I could plugin
> the harddisk from another computer and try to boot into Linux or use the
> small DOS-partition I have on this disk). Or is there some kind of cheat
> password, which will always work? 
> The BIOS is a Phoenix version 4.04.

Reply to: