[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: /usr/src and file permissions

Quoting David J. Kanter (djkanter@nwu.edu):
> I've created/moved my /usr/src to its own partition. However, I've noticed a
> difference in the permissions between the old /usr/src (/usr/oldsrc) and the
> new one, /usr/src.
> drwxrwsr-x    4 root     src          1024 Oct 16 00:18 oldsrc
> drwxr-xr-x    5 root     root         1024 Nov 14 12:33 src
> Could someone explain the difference? I tried setting chmod g=+r+w+s
> /usr/src, but that apparently didn't work.

If you need to chown or chgrp, I would do that first. I'm not sure
of the rules, but sometimes permissions can change when you change

But you need "chmod g+rwxs src" to get the same as oldsrc. If you
leave out the x, you'll get rwS which is setgid but not execute
(even if it was already execute).

I'm assuming that your listing was taken *before* you tried chmod.
If that's not the case, I can't explain why src isn't group write
after chmod g=+r+w+s /usr/src as there should be an error message
if chmod fails.


Email:  d.wright@open.ac.uk   Tel: +44 1908 653 739  Fax: +44 1908 655 151
Snail:  David Wright, Earth Science Dept., Milton Keynes, England, MK7 6AA
Disclaimer:   These addresses are only for reaching me, and do not signify
official stationery. Views expressed here are either my own or plagiarised.

Reply to: