[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

amd mounting local filesystem


Lately I am having (not so much) fun with amd. I am trying to get
it to mount a local filesystem on a mount point of *my* choice.
First I tried this and int works fine:

-------- /etc/amd/amd.master ------------------------
-r -a /amd /home /etc/amd/amd.home

-------- /etc/amd/amd.home --------------------------
students	type:=ufs;dev:=/dev/sda6;opts:=type=ext2,rw,defaults
users		-opts:=rw,nosuid \
		host==samson;type:=ufs;dev:=/dev/vg01/users \
# links
research	type:=link;fs:=users;sublink:=research
guests		type:=link;fs:=users;sublink:=research

This setup mounts /dev/sda6 under /amd/<localhost>/home/students
and makes the link /home/students that points to that
mount point.

Now what I want is to specify a different mount point,
as I understand, by using the fs:=<other mount point> option
in the 'students' map entry. I would like the partition
/dev/sda6 to be mounted under /home/students, so I 
suplied fs:=/home/students. But this did not work. It
caused the /home directory to be inaccessible. If I
tried `cd /home`, cd just hung there and it looks like
I wasn't able to do anything about it. Please tell me
what am I doing wrong. 

Now I come to the second thing that annoyed me very much.
After `cd /home` hung, I wasn't able to get the system to
behave itself again. Killing amd and eveything I thought
had anything in common with the problem solved nothing.
I had to reboot the machine. I hate rebooting the machine.
It spoils my uptime. To be more precise: the system worked 
ok, but anything that touched /home, just froze.


TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: