[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: ncpfs module and kernel recompile



Hi George:

I do my kernel builds a little differently however they always seem to work.

I'll assume that you ran the patch-kernel and got the updated modutils. I don't 
know if the modutils are an absolute requirement however the doc does say
these utils are for 2.1.18 and above.

After I run my "make config" or menuconfig or xconfig, I run make zImage. The
readme in linux says that "If your kernel is too large for "make zImage", use "make bzImage"".
I've used both, they work well.

Following that I do a make install. Everything seems to get copied into /boot.
My filenames are "vmlinuz" as well. When the install asks if I want to run lilo I answer yes.

Following that I go to the root directory rm the existing vmlinux and System.map and re-link them to the newly installed boot image and map. ( ln -s boot/vmlinuz-2.1.29 vmlinuz and ln -s boot/System.map-2.1.29 to System.map). Then I run lilo again and reboot.

I know this is not exactly what the documentation says to do however it always seems to work.

Regards,

peter



----------
From:  G. Kapetanios wrote:

I would be grateful for any help and ideas.,

                                            Thanks
                                            George    






Reply to: