[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Actualizar a testing o reinstalar, he ahí la cuestión



Hola a Todos.


El 13-12-2016 a las 07:48 a.m., JAP escribió:
Buenos días.

Ando en un dilema, de pasar a "testing" mediante actualización o reinstalación, con todo el engorro que significa.

Asumí que una actualización podría ser simple, habida cuenta que "stretch" está semicongelada.

El tema es que los mensajes de alerta de aptitude, dan miedo.
Mientras que apt más o menos dice "¡Ma, sí, dale!"

Pregunta:
Si aptitude es tan quisquilloso, ¿conviene hacer la actualización?

Javier.

Yo he usado testing desde potato y nuca he tenido problemas mayores. Además de eso soy un fanático de aptitude, en especial la interfaz ncurses. Sin embargo, respecto a esto último, está documentado que para dist-upgrade es recomendable hacerlo con apt-get y no con aptitude (si mal no recuerdo lo dice en las notas de la versión -release notes- por lo que te sugiero revisarlas).



Meten miedo las líneas
"¡Incapaz de resolver las dependencias! Desistiendo..."
"¿Desea resolver las dependencias manualmente?"

Este tipo de cosas las manejo sin problemas con aptitude (mediante la interfaz ncurses, es decir #aptitude sin ningún parámetro) las voy mirando y resolviendo una a una, así tengo mejor control de lo que sucede.


A continuación, resumidos, los mensajes de aptitude y apt.
Las líneas (...) significa "un montón más de cosas como la precedente".

#################################################################################

# aptitude dist-upgrade -d
Leyendo lista de paquetes...
Creando árbol de dependencias...
Leyendo la información de estado...
Leyendo la información de estado extendido...
Inicializando el estado de los paquetes...
Leyendo las descripciones de las tareas...
Construir la base de datos de etiquetas...
Se instalarán los siguiente paquetes NUEVOS:
  accountwizard{a} aglfn{a} amd-opencl-icd{a} antlr3.2{a} apport{a}
  (...)
Se ELIMINARÁN los siguientes paquetes:
  aptdaemon{u} aptdaemon-data{u} aspectj{u} aumix{u} aumix-common{u}
  (...)
Se actualizarán los siguientes paquetes:
  abiword-common accountsservice acl acpi-support-base acpid adduser
  (...)
2477 paquetes actualizados, 1357 nuevos instalados, 236 para eliminar y 0 sin actualizar. Necesito descargar 3.574 MB/3.580 MB de ficheros. Después de desempaquetar se usarán 4.385 MB.
No se satisfacen las dependencias de los siguientes paquetes:
libmatroska6v5 : Entra en conflicto: libmatroska6 pero está instalado 1.4.2-dmo3. libbinio1v5 : Entra en conflicto: libbinio1ldbl pero está instalado 1.4+dfsg1-4. kde-style-qtcurve-qt4 : Entra en conflicto: kde-style-qtcurve pero se va a instalar 1.8.14-3+b2. pulseaudio : Entra en conflicto: pulseaudio-module-x11 (< 9.0-2) pero está instalado 5.0-13. mysql-server-core-5.5 : Rompe: virtual-mysql-server-core que es un paquete virtual. mysql-server-core-5.6 : Entra en conflicto: mysql-client-5.5 (< 5.6) pero está instalado 5.5.53-0+deb8u1. Entra en conflicto: mysql-server-core-5.5 pero está instalado 5.5.53-0+deb8u1. Entra en conflicto: virtual-mysql-server-core que es un paquete virtual.
 (...)
¡Incapaz de resolver las dependencias! Desistiendo...
Se instalarán los siguiente paquetes NUEVOS:
  accountwizard{a} aglfn{a} amd-opencl-icd{a} antlr3.2{a} apport{a}
  (...)
Se ELIMINARÁN los siguientes paquetes:
  aptdaemon{u} aptdaemon-data{u} aspectj{u} aumix{u} aumix-common{u}
  (...)
Se actualizarán los siguientes paquetes:
  abiword-common accountsservice acl acpi-support-base acpid adduser
  (...)
2477 paquetes actualizados, 1357 nuevos instalados, 236 para eliminar y 0 sin actualizar. Necesito descargar 3.574 MB/3.580 MB de ficheros. Después de desempaquetar se usarán 4.385 MB. aptitude no pudo encontrar una solución a estas dependencias. Puede solucionar estas dependencias manualmente o pulsar «n» para salir.
No se satisfacen las dependencias de los siguientes paquetes:
libmatroska6v5 : Entra en conflicto: libmatroska6 pero está instalado 1.4.2-dmo3. libbinio1v5 : Entra en conflicto: libbinio1ldbl pero está instalado 1.4+dfsg1-4. kde-style-qtcurve-qt4 : Entra en conflicto: kde-style-qtcurve pero se va a instalar 1.8.14-3+b2. pulseaudio : Entra en conflicto: pulseaudio-module-x11 (< 9.0-2) pero está instalado 5.0-13. mysql-server-core-5.5 : Rompe: virtual-mysql-server-core que es un paquete virtual. mysql-server-core-5.6 : Entra en conflicto: mysql-client-5.5 (< 5.6) pero está instalado 5.5.53-0+deb8u1. Entra en conflicto: mysql-server-core-5.5 pero está instalado 5.5.53-0+deb8u1. Entra en conflicto: virtual-mysql-server-core que es un paquete virtual.
 (...)
¿Desea resolver las depedencias manualmente? [N/+/-/_/:/?]


#################################################################################


# apt-get dist-upgrade -d
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
Calculando la actualización... Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios. aptdaemon aptdaemon-data aspectj aumix aumix-common dh-php5 fgetty (...)
Se instalarán los siguientes paquetes NUEVOS:
  accountwizard aglfn antlr3.2 apport apport-gtk apport-notify (...)
Los siguientes paquetes se han retenido:
  adplug-utils
Se actualizarán los siguientes paquetes:
abiword-common accountsservice acl acpi-support-base acpid adduser (...) 2546 actualizados, 1266 nuevos se instalarán, 136 para eliminar y 1 no actualizados.
Se necesita descargar 3.506 MB/3.512 MB de archivos.
Se utilizarán 4.164 MB de espacio de disco adicional después de esta operación.
¿Desea continuar? [S/n]

#################################################################################

Gracias

JAP


Saludos.

--
Juan M Lavieri

Errar es de humanos, pero es mas humano culpar a los demás.


Reply to: