[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Aventuras instalando hamm



Hola a todos.

Ayer migré de bo a hamm con el apt-get. Y funcionó de maravilla: 1 hora
leyendo documentación
y 15 minutos para tener un sistema con libc6. Hasta aquí, chapeau.

Luego reboto la máquina, hago el cambio del wtmp y el utmp y apago. Horas
más tarde, arranco 
y me meto en el dselect para migrar el resto del sistema. Método de acceso:
apt. Como souce list
del apt pongo el cdrom, donde tengo el CD de Linux Actual (que a mí, con un
6x, no me ha dado 
ningún problema de acceso, ni de botes, etc). 

Pregunta: si hubiera tenido la distribución completa, con el CD de contrib
también, ¿cómo se hace 
para utilizar dos CD's en dselect? 

Otra pregunta: si quiero instalarme paquetes de bo desde dselect, ¿puedo o
no puedo?

Bueno, este no era el caso. Me tiro más de 1 hora navegando por la infinitud
de paquetes, corrigiendo
dependencias, SIN FORZAR ninguna de ellas, y me pongo a instalar. Bueno, a
mitad de instalar, me 
salen errores en varios sitios, entre ellos perl, netbase, ... y se para el
proceso. Trato de configurar los
paquetes que han quedado desconfigurados, y me sigue dando errores en todos
ellos. Es la una y 
media de la mañana... decido ir a dormir y continuar hoy. Hago shutdown y...
no llega al System 
Halted. Tengo que apagar a la brava. 

Hoy por la mañana arranco y me sale el login. Trato de entrar, me salen los
mensajes de bienvenida
y... login otra vez. Sospecho que el bash no funciona. Me instalo hamm (lo
mínimo) desde MS-DOS 
en otra partición linux que montaba para backup. Arrancando desde este nuevo
sistema, monto la 
partición raíz del antiguo y trato de ejecutar el bash del que sospecho.
Mensaje de error: no 
encuentra la librería libncurses.xxxx (no me acuerdo exactamente). Hago ldd
./sh y me salen unas 
cuantas librerías entre las que se encuentran varias que pone Not found, que
deben ser de libc5. 
Hago ldd sh del bash nuevo y no aparece ninguna de las que no encuentra el
otro. Copio el bash
nuevo al sistema viejo, reboto y ya puedo arrancar con normalidad (aún no he
tenido tiempo de ver
en qué estado ha quedado todo).

¿Qué puede haber pasado aquí? No tengo claro qué hacer ahora. ¿Qué tengo que
comprobar y 
en qué orden antes de meterme otra vez con el dselect? 

Una ayudita, please
Gracias anticipadas

Javi


Reply to: