[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: problemas upgrade lenny-squeeze



Mano, uma vez tive um problema parecido, atualizei do debian etch para
o lenny via dist-upgrade, e ocorreram vários problemas, porém, não me
assustei.

Em relação a pacotes que ainda aparecem instalados mas não estão, use
o apt-get -f install, isso irá corrigir e atualizar a lista de pacotes
no sistema, agora cuidado, verifique se com isso também não irá
remover algum pacote essencial. Pode ser que alguns pacotes se
tornaram pacotes quebrados, para ver a lista de pacotes quebrados
digite como root : dpkg -C

sobre o boot, provavelmente na atualização, o kernel também foi
atualizado, verifique se o arquivo do seu gerenciador de boot aponta
para o MAP do kernel certo, assim como a imagem do kernel e o arquivo
initrd se tiver.

Em 01/11/10, linuser<linuser@terra.com.br> escreveu:
> Prezados,
>
> Fiz o upgrade do Lenny para o Squeeze (após meses de hesitação), seguindo
> *todos* os bons conselhos para evitar problemas. Em geral funcionou bem, mas
> restaram alguns problemas ainda sem solução. Por isso recorro à lista.
>
> 1) Aptitude: alguns pacotes parecem que ficaram "órfãos". Por exemplo, o
> kpdf (leitor de pdf que eu gosto muito) aparece na tela do aptitude com a
> seguinte informação:
> aptitude 0.6.3                    Will use 20.4 MB of disk space DL Size:
> 7,200
> c    --\ kpdf                                              <none>     <none>
>
>   --- Packages which depend on kpdf (2)
>   --\ Versions of kpdf (1)
> p    4:3.5.9-3+lenny3
>
> E resulta que eu não consigo instalar o tal kpdf. O problema aqui é que,
> aparentemente, o kpdf não está mais incluido na versão testing (embora
> esteja na stable e na unstable!). As perguntas são:
>
> 1a) por que o kpdf ainda aparece na listagem do aptitude se o meu
> sources.list contém apenas a versão squeeze (que não tem o kpdf)?
>
> 1b) Fato semelhante ocorre com outros pacotes. Aparentemente há um pacotes
> da versão anterior que ainda constam da listagem do aptitude, mas não estão
> (mais) instalados. Como faço para remover este "lixo" da listagem de
> pacotes?
>
> 2) Depois do upgrade, durante o boot passou a haver uma grande quantidade de
> mensagens de erro, mas não é possivel lê-las porque passam muito rápido.
> Como faço para ler estas mensagens depois? dmesg não é a solução, porque
> estas mensagens não estão lá.
>
> Há outros problemas, mas vou quebrar um pouco mais a cabeça antes de
> postá-los.
>
> Agraço qualquer dica.
>
> []'s,
> G.Paulo.
>
>
> --
> To UNSUBSCRIBE, email to debian-user-portuguese-REQUEST@lists.debian.org
> with a subject of "unsubscribe". Trouble? Contact
> listmaster@lists.debian.org
> Archive: 20101101195938.2a3875f8@appia">http://lists.debian.org/20101101195938.2a3875f8@appia
>
>


Reply to: