[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Rede instável



Marcos "Japa" Umino escreveu:
Já está lá: auto eth1 e também auto wlan0
Mais alguma sugestão?

Vou dar um chute: o gateway padrão deveria ser o fornecido pela eth1,
mas o gateway padrão que está "ficando" é o da wlan0.
Correto.
Se for este o caso, temos duas situações: você está usando IP estático
para ambos, ou você está usando DHCP.
IP estático.
No caso de estar usando IP estático, comente a linha de gateway da
interface que não usa para saída padrão.
Feito.
Se estiver usando DHCP na wlan0, vai depender do cliente DHCP que
estiver usando. Alguns clientes (como o default do debian, dhclient)
tem arquivo de configuração em /etc/dhcp3/dhclient.conf. YMMV

Para visualizar isso facilmente, dê um /sbin/route -n, se houverem
duas rotas padrão com mesma métrica, é o problema que estou
"chutando".
Seu chute foi correto. Realmente as duas estavam com a mesma métrica. Apesar de haver comentado a linha referente ao gateway (creio que estamos falando do /etc/network/interfaces) eu reiniciei a máquina e deu o mesmo problema. Para subir a rede, novamente $ sudo route del default ; $ sudo /etc/init.d/networking restart.

Valeu a sugestão, embora não resolvesse o problema. Mais alguma idéia?

Abs

Sérgio

--
Soluções em Automação e Controle
Integrador Autorizado: Metaltex - Atos - Dexter - AllConverge - Dakol - Elipse - Conversoft
Linux User #426387 Linux: A liberdade da escolha. A escolha da liberdade.
      The freedom of the choice. The choice of the freedom.	
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)
iD8DBQFF9vhuJ+YDTomMwA8RAvSAAJoDwkzHJK3P98vEDx5pJxeyT3xyzgCg22/u
W/MTldaxqdeNLjlWF49wpig=
=MVB7
-----END PGP SIGNATURE-----



Reply to: