[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[Re: Postfix+Amavis lento]



Encaminhando para a lista...

-------- Original Message --------
Subject: Re: Postfix+Amavis lento
Date: Fri, 8 Apr 2005 14:58:25 -0300 (BRT)
From: Luiz Gonzaga da Mata <gonzaga@pbh.gov.br>
To: Marcos Vinicius Lazarini <lazarini@nics.unicamp.br>
References: <5DCE1CDE91978540A3092DA869CF7F8A17F5D4@exchange01.intranet.abilis.com.br> <4252C154.2070909@nics.unicamp.br>

Bem, agora em horario de pico, a demora de envio chega em 10 min
quase... A maquina iria apanhar mesmo ou ela deveria aguentar?


Fazendo uma continha rápida:
300000 por dia -> 12500 por hora -> 208,3 por minuto -> 3,472 por segundo


Eu estou achando uma marca bem alta, mesmo pra um P4.
Será que não é problema no seu MTA? As vezes ele não está com uma
configuração adequada... veja como anda o load average de sua máquina,
acesso a disco (iostat, e adjacencias), etc

Passamos por um problema parecido aqui na empresa.

O problema acontecia de o email demorar até 24 hrs para ser
entregue/recebido.

O amavisd tem uma configuração de número de processos servidores que deve
ser configurado de acordo com a memória e processador disponíveis.

Cada processo servidor, consumia em torno de 30 Mb de memória.

A turma trocou o servidor para um de 4 Gb, mas não alterou o número de
processos do amavis.

O que acontecida: Memória disponível e enfileiramento no servidor. Não era
o postix.

Como temos picos de envio/recebimento de email e não média, ia criando uma
fila que só era resolvida depois do expediente processando até o início do
outro dia.

De 10 emails por minuto passamos a ter 25 +-, ou seja, tínhamos uma
contenção de 15 email por minuto.

Me chamaram e costatei este problema.

Um abraço,

Gonzaga.



Reply to: