[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: AVM Capi unter Debian (2.4.18)



* Heike C. Zimmerer <hcz@hczim.de> [03-11-2004 20:43]:

> >   # modprobe fcpci
> >   /lib/modules/2.4.18-686/misc/fcpci.o: kernel-module version mismatch
> >   /lib/modules/2.4.18-686/misc/fcpci.o was compiled for kernel version
> >   2.4.18-4GB 
> >   while this kernel is version 2.4.18-686.
> 
> Beim Compilieren werden die Sources des aktuellen Kernels unter
> /usr/src/linux erwartet.  Dort scheint bei dir was anderes zu liegen.
 
Für mich sieht es eher so aus, als wenn das Modul gar nicht neu 
compiliert wurde. Sonst würde die aktuelle Kernelversion im Modul zu
finden sind. Bei meinem fcdslsl.o Modul teste ich das immer mit:

$ od -s /lib/modules/*/misc/fcdslsl.o | grep kernel_version=

Einfach mal mit fcpci.o testen, ob das auch funktioniert.
Falls da 2.4.18-4GB erscheint - einfach noch mal compilieren.

Gruss Uwe

PS: compilieren, nicht kopieren. ;-)

Attachment: pgpZN42OUeBql.pgp
Description: PGP signature


Reply to: