[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sid-Paket für Woody von Source erstellen: Unmet Dependencies



Hi,

Marc Haber wrote:
> On Mon, 30 Dec 2002 17:19:54 +0100, Marcus Frings
> <iam-est-hora-surgere@fuckmicrosoft.com> wrote:
> >Das Bauen der Pakete funktioniert nicht, weil der Source unbedingt von
> >libperl-dev >= 5.8.0 (a) und libdb4.0-dev (b) abhängen will.
> >(a) ist in Woody in einer zu tiefen Version vorhanden und (b) existiert
> >für Woody nicht (liegt erst in Sarge/Sid) vor.
> 
> für (a) änderst Du die Build-Depends, das funktioniert auch mit perl
> 5.6 (die versioned dependency wird automagisch erzeugt), und für auf

Wir reden hier von den Build-Depends: und da wird gar nichts
automatisch erzeugt....

Diese Versioned Build-Dependency rührt noch von der perl-Tranisition
her, wo das so gemacht werden musste um sicherzugehen, das die
Umstellung auf perl 5.8 reibungslos funktioniert und die Pakete mit
libperl auf jeden Fall gegen die 5.8er gelinkt werden...

Grüße

Rene
-- 
 .''`.  Rene Engelhard -- Debian GNU/Linux Developer
 : :' : http://www.debian.org | http://people.debian.org/~rene/
 `. `'  rene@debian.org | GnuPG-Key ID: 248AEB73
   `-   Fingerprint: 41FA F208 28D4 7CA5 19BB  7AD9 F859 90B0 248A EB73

Attachment: pgpSkB1QM2_yT.pgp
Description: PGP signature


Reply to: