[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: X geeft zwart scherm (ATI Radeon)



Nadat ik een 2GB module uit mijn laptop heb gehaald, werkt X!
Nu alleen nog een work-around voor dit probleem zoeken.

Ook is er nog geen 3D acceleratie.

Bedankt!
Tijmen van der Burgt

2010/5/9 Paul van der Vlis <paul@vandervlis.nl>
Tijmen van der Burgt schreef:
> Hoi,
>
> Ik probeer al een tijdje X werkend te krijgen op mijn laptop (met Debian
> Lenny).
> Helaas krijg ik telkens een zwart scherm als ik X probeer te starten.
> Mijn videokaart is een ATI Mobility Radeon HD3650 (codename: RV635).
>
> Ik heb al verschillende drivers geprobeerd, maar de enige driver waarmee
> ik X aan de praat kreeg, was vesa.
>
> Als eerste heb ik de proprietaire drivers van ATI geprobeerd (fglrx).
> Voorafgaand heb ik eerst non-free sources aan /etc/apt/sources.list
> toegevoegd.
> Vervolgens heb ik 'aptitude update' gedaan, zodat ik de non-free
> packages kan installeren.
>
> De volgende packages heb ik met aptitude geinstalleerd:
> fglrx-modules-2.6-686
> fglrx-control
> fglrx-driver
>
> Daarna heb ik de radeon en drm module geunload:
> modprobe -r radeon drm
>
> Ten slotte, xorg.conf ingesteld, zodat X de fglrx driver gaat gebruiken:
> aticonfig --initial
>
> Zo ziet /etc/X11/xorg.conf er nu uit:
> http://paste.debian.net/72576/plain/72576
>
> Als ik X start krijg ik dus een zwart scherm, de inhoud van
> /var/log/Xorg.0.log:
> http://paste.debian.net/72580/plain/72580
>
> De volgende driver die ik probeer is de opensource radeon driver.
> Ik haal eerst de oude drivers met aptitude weg, en ik installeer:
> xserver-xorg-video-radeon
>
> Ik zet de oude xorg.conf weer terug:
> mv xorg.conf.original-0 xorg.conf
>
> en zet de radeon driver er in:
> http://paste.debian.net/72582/plain/72582
>
> xorg.conf na het starten van X:
> http://paste.debian.net/72584/plain/72584
>
> Ook heb ik radeonhd geprobeerd, waarbij ik tevens een zwart scherm kreeg.
>
> Ik dacht dat de relatief oude versie van X (en de kernel) het probleem
> konden, zijn, dus had ik geupgrade naar Squeeze.
> Helaas daar ook dezelfde resultaten. Ten slotte heb ik ook de installer
> van de AMD site geprobeerd, wat ook een zwart scherm gaf.
>
> Hopelijk heeft iemand ervaring met eenzelfde kaart, en zou me hier mee
> kunnen helpen?
>
>
> Bedankt,
> Tijmen van der Burgt
>
>
>

Er schijnt een bug te zijn m.b.t. veel geheugen. Lees dit misschien:
http://lists.opensuse.org/radeonhd/2009-04/msg00253.html

Verder is "phoronix.com" de site met veel informatie over ATI en de
radeonhd driver. Er wordt al veel ondersteund in kernel 2.6.32, in elk
geval de "Radeon HD 3200 Graphics" die ik heb wel.

Ik had onlangs een vergelijkbaar probleem met een andere videokaart. Heb
toen een bugreport ingediend op "xserver-xorg-core", en er kwam binnen 2
weken een goede oplossing. Dus wellicht een tip.

Met vriendelijke groet,
Paul van der Vlis.




--
http://www.vandervlis.nl/


--
To UNSUBSCRIBE, email to debian-user-dutch-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org



Reply to: