[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

[Debian]: ssh, Automatisches Ausfuehren eine Programmes auf der Remoten Station (X11)



Nun zu einem zweiten Problem was mich seit einigen Tagen beschaeftigt:

Lt. man-Page zu ssh sollte es ueber die Option -n bzw. -f moeglich sein,
auf der Remoten Station ein Programm auszufuehren. Ich moechte z.B.
durch den Aufruf:
"ssh -f wa301241 xterm" ein xterm auf wa301241 starten.

Die Authentisierung ist erfolgreich (ein ssh wa301241 geht automatisch
ohne Passwordabfrage ) nur meldet mir dann eine bash (welche?) ´bash:
xterm: command not found´. Warum?

Im Debugging Modus von ssh sieht das ganze so aus:


wa301177:~<stephan>$ ssh -v -f wa301241 xterm
SSH Version 1.2.26 [i486-unknown-linux], protocol version 1.5.
Standard version.  Does not use RSAREF.
wa301177: Reading configuration data /etc/ssh/ssh_config
wa301177: ssh_connect: getuid 1000 geteuid 0 anon 0
wa301177: Connecting to wa301241 [164.19.229.117] port 22.
wa301177: Allocated local port 1021.
wa301177: Connection established.
wa301177: Remote protocol version 1.5, remote software version 1.2.26
wa301177: Waiting for server public key.
wa301177: Received server public key (768 bits) and host key (1024
bits).
wa301177: Host 'wa301241' is known and matches the host key.
wa301177: Initializing random; seed file /home/stephan/.ssh/random_seed
wa301177: Encryption type: idea
wa301177: Sent encrypted session key.
wa301177: Installing crc compensation attack detector.
wa301177: Received encrypted confirmation.
wa301177: Trying rhosts or /etc/hosts.equiv with RSA host
authentication.
wa301177: Remote: Accepted by .rhosts.
wa301177: Received RSA challenge for host key from server.
wa301177: Sending response to host key RSA challenge.
wa301177: Remote: Rhosts with RSA host authentication accepted.
wa301177: Rhosts or /etc/hosts.equiv with RSA host authentication
accepted by server.
wa301177: Requesting X11 forwarding with authentication spoofing.
wa301177:~<stephan>$ wa301177: Sending command: xterm
wa301177: Entering interactive session.
wa301177: Sending eof.
bash: xterm: command not found
wa301177: Transferred: stdin 0, stdout 31, stderr 0 bytes in 0.2 seconds
wa301177: Bytes per second: stdin 0.0, stdout 186.3, stderr 0.0
wa301177: Exit status 127

Ohne Debugging erhalte ich nur folgeden Aussage:
wa301177:~<stephan>$ ssh -f wa301241 xterm 
bash: xterm: command not found

An dieser Stelle haegt das (locale) xterm.

Nicht zu erwaehnen brauche ich, dass es funktioniert, wenn ich das ganze
in zwei Schritten ausfuehre.
1. ssh  wa301241
2. xterm 

Auf allen Rechnern laeuft die Version: 

ii  ssh             1.2.26-1       a secure replacement for rlogin, rsh,
and rc

Kennt jemand das Problem und hat eine Loesung dafuer gefunden?    

Danke im voraus

Stephan
------------------------------------------------
Um sich aus der Liste auszutragen schicken Sie
bitte eine E-Mail an majordomo@jfl.de die im Body
"unsubscribe debian-user-de <your_email_address>"
enthaelt.
Bei Problemen bitte eine Mail an: Jan.Otto@jfl.de
------------------------------------------------
Anzahl der eingetragenen Mitglieder:     648


Reply to: