[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#677607: Fails to upgrade 3.11 → 3.12 (updmap-sys failed)

Package: tex-common
Version: 3.11
Severity: important

Hi there,

Not filing as RC as I cannot reproduce in a chroot, but maybe you want
to upgrade.

I get an upgrade failure when trying to go from 3.11  3.12:

| laney@polihale> sudo dpkg --configure tex-common
| Setting up tex-common (3.11) ...
| Running mktexlsr. This may take some time... done.
| Running updmap-sys. This may take some time... 
| updmap-sys failed. Output has been stored in
| /tmp/updmap.74tEttrb
| Please include this file if you report a bug.
| Sometimes, not accepting conffile updates in /etc/texmf/updmap.d
| causes updmap-sys to fail.  Please check for files with extension
| .dpkg-dist or .ucf-dist in this directory
| dpkg: error processing tex-common (--configure):
|  subprocess installed post-installation script returned error exit
|  status 1
|  Errors were encountered while processing:
|   tex-common

The contents of that file are:

| Can't locate TeXLive/TLUtils.pm in @INC (@INC contains: //tlpkg
| /etc/perl /usr/local/lib/perl/5.14.2 /usr/local/share/perl/5.
| 14.2 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.14
| /usr/share/perl/5.14 /usr/local/lib/site_perl .) at /usr/bin/updmap l
| ine 21.
| BEGIN failed--compilation aborted at /usr/bin/updmap line 21.

I don't think I've messed with @INC. Pointers on where to look welcomed.


-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (1, 'experimental')
Architecture: i386 (i686)

Kernel: Linux 3.2.0-2-686-pae (SMP w/2 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8) (ignored: LC_ALL set to en_GB.UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages tex-common depends on:
ii  debconf [debconf-2.0]  1.5.43
ii  dpkg         
ii  ucf                    3.0025+nmu3

tex-common recommends no packages.

Versions of packages tex-common suggests:
ii  debhelper  9.20120608

Versions of packages texlive-base depends on:
ii  debconf [debconf-2.0]  1.5.43
ii  dpkg         
ii  install-info           4.13a.dfsg.1-10
ii  libpaper-utils         1.1.24+nmu2
ii  luatex       
ii  mime-support           3.52-1
iu  texlive-binaries       2012.20120516-1
ii  texlive-common         2011.20120410-1
ii  texlive-doc-base       2011.20120322-1
ii  ucf                    3.0025+nmu3

Versions of packages texlive-base recommends:
ii  lmodern  2.004.1-5

Versions of packages texlive-base suggests:
ii  evince [postscript-viewer]       3.2.1-1+b1
ii  ghostscript [postscript-viewer]  9.05~dfsg-6
pn  perl-tk                          <none>
ii  xpdf [pdf-viewer]                3.03-9

Versions of packages texlive-binaries depends on:
ii  dpkg  
ii  ed              1.6-2
ii  install-info    4.13a.dfsg.1-10
ii  libc6           2.13-33
ii  libfontconfig1  2.9.0-6
ii  libfreetype6    2.4.9-1
ii  libgcc1         1:4.7.0-13
ii  libgraphite3    1:2.3.1-0.2
ii  libkpathsea6    2012.20120530-2+b1
ii  libpng12-0      1.2.49-1
ii  libpoppler13    0.16.7-3
ii  libptexenc1     2012.20120530-2+b1
ii  libstdc++6      4.7.0-13
ii  libx11-6        2:
ii  libxaw7         2:1.0.10-2
ii  libxmu6         2:1.1.1-1
ii  libxpm4         1:3.5.10-1
ii  libxt6          1:1.1.3-1
ii  perl            5.14.2-11
ii  texlive-common  2011.20120410-1
ii  zlib1g          1:1.2.7.dfsg-11

Versions of packages texlive-binaries recommends:
ii  luatex
ii  python          2.7.3~rc2-1
ii  ruby            4.8
ii  ruby1.8 [ruby]
ii  texlive-base    2011.20120410-1
ii  tk8.4 [wish]    8.4.19-5
ii  tk8.5 [wish]    8.5.11-2

-- debconf information:
  texlive-base/binary_chooser: pdftex, dvips, dvipdfmx, xdvi

Iain Lane                                  [ iain@orangesquash.org.uk ]
Debian Developer                                   [ laney@debian.org ]
Ubuntu Developer                                   [ laney@ubuntu.com ]
PhD student                                       [ ial@cs.nott.ac.uk ]

Reply to: