[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#530747: gmp: Please support Renesas SuperH archtechture

Package: gmp
Severity: wishlist
Tags: patch


I am porting of Renesas SH in Debian. 
The current gmp package doen't support SH and can not build. 
I made a patch to revise to be able to build. 
Would you apply it? 

Best regards,

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.29-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=ja_JP.UTF-8, LC_CTYPE=ja_JP.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Nobuhiro Iwamatsu
	GPG ID: 3170EBE9
--- debian/gmp.h.orig	2009-05-25 11:09:12.000000000 +0900
+++ debian/gmp.h	2009-05-25 11:09:25.000000000 +0900
@@ -57,6 +57,8 @@
 #include "gmp-x86_64.h"
 #elif defined(__alpha__)
 #include "gmp-alpha.h"
+#elif defined(__sh__)
+#include "gmp-sh.h"
 #error "The gmp-dev package is not usable with the architecture."

Reply to: