[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#512722: openssh-client: message "Warning: No xauth data..." after upgrading. Can't forward X11.

Package: openssh-client
Version: 1:5.1p1-5
Severity: important

I can no more use remote X11 forwarding.
When I ssh -Y or ssh -X I get this message:

Warning: No xauth data; using fake authentication data for X11 forwarding.

if I try for example to launch xeyes, I get:

Invalid MIT-MAGIC-COOKIE-1 keyError: Can't open display: localhost:12.0

never happened before.
I have a working /usr/bin/xauth executable in both machines.

-- System Information:
Debian Release: 5.0
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.28-1.slh.1-sidux-amd64 (SMP w/2 CPU cores; PREEMPT)
Locale: LANG=it_IT.UTF-8, LC_CTYPE=it_IT.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages openssh-client depends on:
ii  adduser               3.110              add and remove users and groups
ii  debconf [debconf-2.0] 1.5.24             Debian configuration management sy
ii  dpkg                  1.14.24            Debian package management system
ii  libc6                 2.9-0exp1          GNU C Library: Shared libraries
ii  libcomerr2            1.41.3-1           common error description library
ii  libedit2              2.11~20080614-1    BSD editline and history libraries
ii  libkrb53              1.6.dfsg.4~beta1-5 MIT Kerberos runtime libraries
ii  libncurses5           5.7+20090110-1     shared libraries for terminal hand
ii  libssl0.9.8           0.9.8g-15          SSL shared libraries
ii  passwd                1:4.1.1-6          change and administer password and
ii  zlib1g                1:  compression library - runtime

Versions of packages openssh-client recommends:
ii  openssh-blacklist             0.4.1      list of default blacklisted OpenSS
ii  openssh-blacklist-extra       0.4.1      list of non-default blacklisted Op
ii  xauth                         1:1.0.3-2  X authentication utility

Versions of packages openssh-client suggests:
pn  keychain                      <none>     (no description available)
pn  libpam-ssh                    <none>     (no description available)
pn  ssh-askpass                   <none>     (no description available)

-- no debconf information

Reply to: