[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Net install of woody fails on SparcStation IPX (sun4c)

At 22:37 +1000 3/28/05, Ben Stanley wrote:

I have an old SparcStation IPX which used to run RedHat 6.1, and I
decided to see if I could get something reasonably modern running on it.
Well, I've tried Splack 8 [0], and while it worked, its rather old.
Splack 10 beta had a lot of 'unimplemented instruction' errors. I wasn't
keen to try compiling the world on Gentoo. I thought I'd have a go with
Debian - I've not used it before (unless Ubuntu counts...).

I saw a few discussions on this list saying that sarge does not support
the sun4c architecture, and that sun4c people should stick with woody
[1]. I did try to net-boot the sarge images, and I can verify that they
don't work...

Since I don't have a CDROM unit, and the floppy drive is foo-bar, I
thought I'd do a network installation according to the instructions [2].
I configured rarpd and set up my tftp server, and sniffed things with
ethereal to figure out why things weren't working, until I got it to
start downloading the boot image. That is, I am serving the tftpboot.img
file [3] from my tftp server. The file is saved on my server as
/tftpboot/C0A8010D.SUN4C , being the ip address in hex followed by the
machine architecture.

When I turn on the sparcstation, I am at first confronted by invalid
nvram contents. This is fixed using techniques outlined by [5]. (BTW,
I'm interested in a place to get a new clock chip cheap in .au. I've
been quoted the order of AU$60.) Then I do a
ok boot net
SPARCstation IPX, Type 4 Keyboard
ROM Rev. 2.4, 48 MB memory installed, Serial #847320.
Ethernet address 8:0:20:c:ed:d8, Host ID: 570cedd8.
Rebooting with command: net
Boot device: /sbus/le@0,c00000   File and args:
307c00                          <-- packet counter - takes a few minutes
Booting Linux...

and at that point the machine stops. No friendly penguin icon. No kernel
boot messages. I am not able to reset the machine using shift-stop-a. I
am forced to power cycle.

While the tftpboot.img file seems foo-bar on this machine, the
linux-a.out file [4] does boot. While the kernel does start, it panics
when it can't find a root filesystem to mount. I suppose I could supply
an nfs root and see how far I get with that.

The main reason I am writing is because woody supposedly supports sun4c,
and the network installation seems to be broken.

Thanks in advance for any help,
Ben Stanley.

I will not make you feel any good, but I have the ver same problem. Only way I had to install woody in my IPX was to boot from disk 1 in a cdrom. :P

[0] http://www.splack.org/
[1] http://lists.debian.org/debian-sparc/2005/01/msg00152.html
[5] http://www.squirrel.com/squirrel/sun-nvram-hostid.faq.html

To UNSUBSCRIBE, email to debian-sparc-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: