[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: patched 2.4.18 woody kernel image packages

I tested the kernel with success. :)

Is only the uselib() root exploit fixed ?

I looked at http://www.isec.pl/vulnerabilities.html and saw also a other problem and I think this should be solved ( kernel-image-2.4.18-1-686-smp can be affected).

On http://www.isec.pl/vulnerabilities04.html you can see more problemes , they we should check. Is a list of all security problems available ?
(to read all ChangesLogs are not really helpful)

I hope on 2.6 with the new as-tree (e.g. 2.6.10-as2) , we will get a collections of all securty problems and it is easier to handle.

Nice greetings,

Brett Hamilton wrote:
Dear Debian Users,

Due the to delay of security updated debian woody 2.4.18 kernels, I have
applied Simon Heywood's patch to the kernel-source-2.4.18 (ver 14.3) and
am making deb packages available for 386 and 686.

These kernels have been tested to stop the uselib() kernel root exploit.


We hope that this release will help improve the security on systems
presently running version 13.1 of kernel-image-2.4.18.

These kernel packages have been installed and appear to function well, but
they are still rather new and come with no warranty. Feel free to give
them a try, and let me know if you experience any problems.




Harald Krammer
Brucknerstrasse 33
A - 4020  Linz

Mobil +43.(0) 664. 130 59 58
Mail: hkrammer@a1.net

Please avoid sending me Word or PowerPoint attachments.

Reply to: