[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: More SSH Fun (X11 forwarding)



This one time, Norbert Preining wrote:
> On Mon, 01 Jul 2002, Anne Carasik wrote:
> > Let me know if you have any ideas. Running the client and server in both
> > verbose and debugging modes provides me with nothing useful :(
> Did you set 
> 	X11Forwarding yes
> in both sshd_config on server and ssh_config (.ssh/config) on client?

It doesn't matter about the sshd_config, only the ssh_config on the
client. Anyway, they are both set to 

 X11Forwarding yes

The only other changes I've made are the following:

If I set X11UseLocalhost to yes on the server, I get this:

 server:/home/gator- xterm
 xterm Xt error: Can't open display: 

 server:/home/gator- echo $DISPLAY
 DISPLAY: Undefined variable.
                             
If I set X11UseLocalhost to no, I get this:

 server:/home/gator- xterm
 xterm Xt error: Can't open display: 

 server:/home/gator- xterm
 xterm Xt error: Can't open display: server:10.0

So, if I force X11 with the -X (even though my ssh_config on
the client is set to X11Forwarding yes), I get this:

So, it looks like I have to have X11UseLocalhost set to no,
but I still can't open the X11.
                            
Any ideas? Also, I did HUP the server between changes. :)

-Anne
-- 
              .-"".__."``".   Anne Carasik, System Administrator
 .-.--. _...' (/)   (/)   ``'   gator at cacr dot caltech dot edu 
(O/ O) \-'      ` -="""=.    ',  Center for Advanced Computing Research    
~`~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Attachment: pgpoVykecuajy.pgp
Description: PGP signature


Reply to: