[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Still Unable to Print in Russian

HC> БОЛЬШОЕ СПАСИБО!!!!  Теперь я могу печатать по-русски.  Но мой
HC> "printer" ещё не может печать.  English letters print correctly,
HC> but Russian letters are not correct.  Что я делаю теперь?

AK>> Читаешь это:
AK>> http://bass.edinstvo.com/rdeb.html
AK>> http://people.debian.org/~nidd/
AK>> http://www.inp.nsk.su/~baldin/

I will be happy if I ever learn to read Russian one-tenth as well as I
read English.   :-(

I downloaded and installed (?) Postscript Type 1 fonts. However, I am
still not able to print in Russian.  I am not sure whether I have
properly installed the Postscript fonts.

-Harold Crouch


***** Step 1:  Choose encoding method.
The preferred encoding is KOI8-R

***** Step 2: Install X fonts.
"apt-get install xfonts-bolkhov-koi8r-75dpi" and 
"apt-get install xfonts-cronyx-koi8r-75dpi."  

***** Step 3: Build locale
/etc/locale.gen contained one line; I added the second line.

     en_US ISO-8859-1
     ru_RU KOI8-R

After adding the second line, I ran "locale-gen."

***** Step 4: Modify the Bash environment.
I added the following line to /etc/profile:

     export LC_CTYPE=ru_RU.KOI8-R

***** Step 5: Modify /etc/X11/XF86Config-4
I added the last two lines to the "InputDevice" section

     Section "InputDevice"
	Identifier	"Default Keyboard"
	Driver		"keyboard"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xfree86"
	Option		"XkbModel"	"pc104"
	Option		"XkbLayout"	"us"
	Option		"XkbLayout"	"ru"
	Option		"XkbOptions"	"grp:ctrl_shift_toggle,grp_led:scroll"

The following is the "Files" section.  
My computer does *not* have a "/usr/lib/X11/cyrillic" folder.  
I did not place this line in the configuration file.

   Section "Files"
	FontPath	"unix/:7100"
	FontPath	"/usr/lib/X11/fonts/misc"
	FontPath	"/usr/lib/X11/fonts/cyrillic"
	FontPath	"/usr/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/Type1"
	FontPath	"/usr/lib/X11/fonts/TrueType"
	FontPath	"/usr/lib/X11/fonts/Speedo"
	FontPath	"/usr/lib/X11/fonts/75dpi"
	FontPath	"/usr/share/fonts/truetype"
	FontPath	"/usr/share/fonts/truetype/openoffice"

***** Step 6:  Activate all this stuff.
I rebooted my computer.

***** Step 7: Use it.
I configured Mozilla and Sylpheed to use the KOI8-R fonts.  I  now can
view web pages encoded in KOI8-R, and I can send and receive e-mails
encoded in KOI8-R.  (The <shift-ctrl> key combination toggles the
keyboard between the two encodings.)

***** Step 8: Print (1st attempt)
I am using LPRng.  

ASCII characters print as expected; but cyrillic characters are
transposed into garbage.  I think that I need "pfa/pfb" fonts.  

***** Step 9: Download and install Postscript Type 1 fonts. 
I downloaded

I unpacked them and copied them into /usr/share/fonts/type1/gsfonts. 

The names of the fonts I copied into the folder perfectly matched the
names of the existing files, but the new files are larger.  

There are two new files in the directory: fonts.dir and fonts.scale. 
I believe that these files are used only by Abiword, so I will ignore
them for now.

I then executed the following command: 

  defoma-font -q reregister-all /etc/defoma/hints/gsfonts.hints.

I did *not*  change anything in the /etc/printcap file. 

***** Step 10: Print (2nd attempt)
Reboot and...

Russian characters still do not print correctly.

Reply to: