[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#687477: unblock: poco/1.3.6p1-4

Hi Adam,

On Thu, Sep 13, 2012 at 07:23:00AM +0100, Adam D. Barratt wrote:
> Control: tags -1 + moreinfo
> On Thu, 2012-09-13 at 07:53 +0200, Andreas Tille wrote:
> > while poco seems to be removed from testing due to some longer standing
> > RC bugs there are packages (build-)depending from it remaining in
> > testing (example: sitplus, see #680798).
> There seems to be some confusion here.  sitplus is _not_ in testing.  It
> hasn't been in testing since June.

Uhmmm, sorry for the confusion.  I never realised that it was removed.
(I think I even somehow ignored one of your hints about this fact in the
past because I was somehow sure that it was in ...)

I can only tell for sure that sitplus was in testing at the point of
creation of the Debian Med metapackages because it is recommended in
med-rehabilitation.  This was in April and we did not recieved any RC
bug against sitplus so I did not checked - perhaps it was just removed
because of the missing Dependency.

BTW, I did not recieved any response to my "Blends metapackages upload
*after* freeze" mail[1].  The Recommends in med-rehabilitation would be
fixed by a new upload - but in principle it would be prefered to have
sitplus inside wheezy if possible.

> Without a lot of persuading, britney won't allow there to be packages in
> testing which depend on packages which aren't also in testing.  Build
> dependencies aren't enforced, but a review of the Sources files for
> testing didn't show any packages Build-Depending on poco; would you be
> able to specify those?



It lists libpoco-dev as Build-Depends and #680798 is exactly about the
lack of the required Build-Depends.

Kind regards


[1] https://lists.debian.org/debian-release/2012/06/msg00323.html


Reply to: