[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#680898: build-depends on gcc-4.5/g++-4.6; build-conflicts against obsolete gcc version on x86

Philipp Kern, le Mon 09 Jul 2012 08:22:37 -0600, a écrit :
> On Mon, Jul 09, 2012 at 06:24:09AM +0200, Samuel Thibault wrote:
> > Philipp Kern, le Sun 08 Jul 2012 17:17:47 -0600, a écrit :
> > > starpu-contrib build-depends on gcc-4.5/g++-4.5 which should go away (see [0]).
> > > It also build-conflicts against gcc-4.6/g++-4.6, which are not the default
> > > compilers of x86 in wheezy anymore.
> > The problem is that nvcc tries to use the latest installed gcc, but
> > does not actually support all of its syntax, leading to build failures.
> > That's why this situation, which should be fine for wheezy.  Wheezy+1,
> > with a newer nvcc, will probably be an entirely different story.
> We're aiming to remove gcc-4.5 from wheezy,


> so I'm not sure how it can be fine for it.

> And can it actually be rebuilt given that 4.7 would be picked?

No, nvcc only picks 4.6 at best.

Another way is trying to cripple the source into not using the syntax
that nvcc doesn't support.


Reply to: