[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#618612: kaddressbook: fails to connect with SSL for LDAP to a global catalog

Package: kaddressbook
Version: 4:4.4.7-3
Severity: normal

The global catalog service is used for Exchange GAL to distribute the
global contacts. Access is possible with LDAP on port 3268 without SSL
and on port 3269 with SSL. With the Kaddressbook LDAP Server settings
set to connect without SSL on port 3268 it works without problems. With
enabled SSL on port 3269 it doesn't work. The error is

Could not connect to host
Additional info: .

The same configuration on icedove works without problems with SSL.

Thank you for your work



-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (700, 'testing'), (600, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.36 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages kaddressbook depends on:
ii  kdebase-runtime               4:4.4.5-1  runtime components from the offici
ii  kdepim-runtime                4:4.4.7-1  Runtime components for akonadi-kde
ii  libakonadi-contact4           4:4.4.5-2  library for using the Akonadi PIM 
ii  libakonadi-kde4               4:4.4.5-2  library for using the Akonadi PIM 
ii  libc6                         2.11.2-11  Embedded GNU C Library: Shared lib
ii  libgcc1                       1:4.5.2-4  GCC support library
ii  libgpgme++2                   4:4.4.5-2  c++ wrapper library for gpgme
ii  libkabc4                      4:4.4.5-2  library for handling address book 
ii  libkdecore5                   4:4.4.5-3  the KDE Platform Core Library
ii  libkdepim4                    4:4.4.7-3  KDE PIM library
ii  libkdeui5                     4:4.4.5-3  the KDE Platform User Interface Li
ii  libkio5                       4:4.4.5-3  the Network-enabled File Managemen
ii  libkldap4                     4:4.4.5-2  library for accessing LDAP
ii  libkleo4                      4:4.4.7-3  certificate based crypto library
ii  libkontactinterface4          4:4.4.5-2  Kontact interface library
ii  libkparts4                    4:4.4.5-3  the Framework for the KDE Platform
ii  libkpimidentities4            4:4.4.5-2  library for managing user identiti
ii  libkutils4                    4:4.4.5-3  various utility classes for the KD
ii  libqgpgme1                    4:4.4.5-2  library for GpgME++ integration wi
ii  libqt4-dbus                   4:4.6.3-4  Qt 4 D-Bus module
ii  libqtcore4                    4:4.6.3-4  Qt 4 core module
ii  libqtgui4                     4:4.6.3-4  Qt 4 GUI module
ii  libstdc++6                    4.5.2-4    The GNU Standard C++ Library v3

kaddressbook recommends no packages.

Versions of packages kaddressbook suggests:
ii  kdepim-kresources             4:4.4.7-3  KDE PIM resource plugins

-- no debconf information

Reply to: