[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#584375: marked as done (pkg-kde-tools: FTBFS: tests failed)

Your message dated Thu, 03 Jun 2010 22:18:41 +0000
with message-id <E1OKIkL-0005pv-2R@ries.debian.org>
and subject line Bug#584375: fixed in pkg-kde-tools 0.9.1
has caused the Debian Bug report #584375,
regarding pkg-kde-tools: FTBFS: tests failed
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

584375: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=584375
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Source: pkg-kde-tools
Version: 0.9.0
Severity: serious
Tags: squeeze sid
User: debian-qa@lists.debian.org
Usertags: qa-ftbfs-20100602 qa-ftbfs
Justification: FTBFS on amd64


During a rebuild of all packages in sid, your package failed to build on

Relevant part:
> make[1]: Entering directory `/build/user-pkg-kde-tools_0.9.0-amd64-OM7TiW/pkg-kde-tools-0.9.0'
> ./run-local perl -MTest::Harness -e '$Test::Harness::verbose=0; runtests @ARGV;' t/*.t
> pkgkde-getbuildlogs: error: in order to use this utility, you have to install libwww-perl package
> BEGIN failed--compilation aborted at pkgkde-getbuildlogs line 34.
> #   Failed test 'Syntax check of pkgkde-getbuildlogs'
> #   at t/perl_syntax_check.t line 25.
> #          got: '0'
> #     expected: anything else
> # Looks like you failed 1 test of 22.
> t/perl_syntax_check.t .. 
> Dubious, test returned 1 (wstat 256, 0x100)
> Failed 1/22 subtests 
> Test Summary Report
> -------------------
> t/perl_syntax_check.t (Wstat: 256 Tests: 22 Failed: 1)
>   Failed test:  21
>   Non-zero exit status: 1
> Files=1, Tests=22,  1 wallclock secs ( 0.02 usr  0.00 sys +  0.90 cusr  0.20 csys =  1.12 CPU)
> Result: FAIL
> Failed 1/1 test programs. 1/22 subtests failed.
> make[1]: *** [test] Error 1

The full build log is available from:

A list of current common problems and possible solutions is available at 
http://wiki.debian.org/qa.debian.org/FTBFS . You're welcome to contribute!

About the archive rebuild: The rebuild was done on about 50 AMD64 nodes
of the Grid'5000 platform, using a clean chroot.  Internet was not
accessible from the build systems.

| Lucas Nussbaum
| lucas@lucas-nussbaum.net   http://www.lucas-nussbaum.net/ |
| jabber: lucas@nussbaum.fr             GPG: 1024D/023B3F4F |

--- End Message ---
--- Begin Message ---
Source: pkg-kde-tools
Source-Version: 0.9.1

We believe that the bug you reported is fixed in the latest version of
pkg-kde-tools, which is due to be installed in the Debian FTP archive:

  to main/p/pkg-kde-tools/pkg-kde-tools_0.9.1.dsc
  to main/p/pkg-kde-tools/pkg-kde-tools_0.9.1.tar.bz2
  to main/p/pkg-kde-tools/pkg-kde-tools_0.9.1_all.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 584375@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Modestas Vainius <modax@debian.org> (supplier of updated pkg-kde-tools package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.8
Date: Fri, 04 Jun 2010 01:04:28 +0300
Source: pkg-kde-tools
Binary: pkg-kde-tools
Architecture: source all
Version: 0.9.1
Distribution: unstable
Urgency: low
Maintainer: Debian Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
Changed-By: Modestas Vainius <modax@debian.org>
 pkg-kde-tools - various packaging tools and scripts for KDE Applications
Closes: 584375
 pkg-kde-tools (0.9.1) unstable; urgency=low
   * pkgkde-getbuildlogs: load HTTP::Request & friends in the INIT block in
     order to pass syntax check without libwww-perl installed (Closes: #584375).
 31ffa19d310eaa883211b5e12626418b49326263 976 pkg-kde-tools_0.9.1.dsc
 a3357441396dd4e0f831e5a1b3813acf1de00075 59531 pkg-kde-tools_0.9.1.tar.bz2
 49a42ff3329933f1ecc61a87857bacd10a270652 88000 pkg-kde-tools_0.9.1_all.deb
 0ccb2233e40fe7af57d934a121620a2a35454ee2f0329f02a2347753d3e39669 976 pkg-kde-tools_0.9.1.dsc
 5e2202ebeba0e3da95bb3fa9101b667137a31aca43e342873ee9787b9078d74e 59531 pkg-kde-tools_0.9.1.tar.bz2
 7f0c30de5bada861f28ab4755211922ee572a396824306ce98777d94c514580f 88000 pkg-kde-tools_0.9.1_all.deb
 10177f01ae248494e79e896a4ea668bc 976 devel extra pkg-kde-tools_0.9.1.dsc
 c06a6aff04bdc25add39c8bc96023ac2 59531 devel extra pkg-kde-tools_0.9.1.tar.bz2
 9c3257aa5d8cdc232e7b6c64b7a2d505 88000 devel extra pkg-kde-tools_0.9.1_all.deb

Version: GnuPG v1.4.10 (GNU/Linux)


--- End Message ---

Reply to: