[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#540113: python-kde4: package not installable because of strange python-qt4 dependency

Package: python-kde4
Version: 4:4.2.4-2
Severity: grave
Justification: renders package unusable

The package has got this dependency on python-qt4: python-qt4 (>= 4.5.1-1), python-qt4 (<< 4.5.1-1+~)

This makes the package uninstallable in sid because there was a NMU to python-qt4,
which is now 4.5.1-1.1 .

The following packages have unmet dependencies:
  python-kde4: Depends: python-qt4 (< 4.5.1-1+~) but 4.5.1-1.1 is to be installed
  E: Broken packages

-- System Information:
Debian Release: squeeze/sid
  APT prefers unstable
  APT policy: (990, 'unstable'), (700, 'experimental'), (500, 'experimental'), (500, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.30-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=de_DE.UTF-8, LC_CTYPE=de_DE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages python-kde4 depends on:
ii  kdebase-runtime           4:4.2.4-2      runtime components from the offici
ii  kdelibs5                  4:4.2.4-1      core libraries for all KDE 4 appli
ii  kdepimlibs5               4:4.2.4-1      core libraries for KDE PIM 4 appli
ii  libc6                     2.9-23         GNU C Library: Shared libraries
ii  libgcc1                   1:4.4.1-1      GCC support library
ii  libphonon4                4:4.5.2-1      Qt 4 Phonon module
ii  libplasma3                4:4.2.4-1      library for the KDE 4 Plasma deskt
ii  libqt4-network            4:4.5.2-1      Qt 4 network module
ii  libqt4-svg                4:4.5.2-1      Qt 4 SVG module
ii  libqt4-xml                4:4.5.2-1      Qt 4 XML module
ii  libqtcore4                4:4.5.2-1      Qt 4 core module
ii  libqtgui4                 4:4.5.2-1      Qt 4 GUI module
ii  libsoprano4               2.3.0+dfsg.1-2 libraries for the Soprano RDF fram
ii  libstdc++6                4.4.1-1        The GNU Standard C++ Library v3
ii  phonon                    4:4.5.2-1      Qt 4 Phonon module metapackage
ii  python                    2.5.4-2        An interactive high-level object-o
pn  python-qt4                <none>         (no description available)
pn  python-sip4               <none>         (no description available)
ii  python-support            1.0.3          automated rebuilding support for P
ii  python2.5                 2.5.4-1        An interactive high-level object-o

python-kde4 recommends no packages.

python-kde4 suggests no packages.

Reply to: