[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#337527: marked as done (kaddressbook lacks a dependency)



Your message dated Sun, 27 Aug 2006 12:17:56 -0400
with message-id <200608271218.04105.chrsmrtn@debian.org>
and subject line Closing bugs fixed in latest kdepim upload (4:3.5.4-1)
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: kaddressbook
Version: 3.4.2-2

When installing the package and trying to configure it the following
error messsage is given when asking the ldap server for the base DN.

"
Could not start process Unable to create io-slave:
klauncher said: Unknown protocol 'ldap'.
"

I suggest adding a dependency on kdebase-kio-plugins which contains the
io-slave.
--
/Martin


--- End Message ---
--- Begin Message ---
Version: 4:3.5.4-1

Though technically the latest kdepim upload was a NMU, for all intents 
and purposes it was a Qt/KDE team upload, so I'm formally closing the 
bugs it fixed. Appended is the changelog with details.

Cheers,
Christopher Martin


kdepim (4:3.5.4-1) unstable; urgency=low

* New upstream release.

+++ Changes by Fathi Boudra:

* Branch pull to revision 577416, minus the akregator feeddetector 
changes which don't build.

* Added kdepim extra debug information from KDE bug #104956. Users of 
d-imap will have to put up with extra dialogs, but this is hopefully 
only until the d-imap data loss issues are worked out (some work on 
that problem is in this upload, but it hasn't been confirmed to fix the 
problem).

* Removed autotools-dev from the Build-Depends; automake1.9 depends on 
it.

+++ Changes by Christopher Martin:

* Packaging sync with the rest of the team KDE packages. Update package 
descriptions, sync debian-qt-kde.mk and other CDBS stuff (should help 
building on slow architectures). Also fixes a package description typo.
(Closes: #364138)

* Remove patch that disabled --enable-final for kmail, now that we 
disable it globally on m68k and arm. We'll see if the other 
architectures can truly cope.

* Change dependencies on kdepim-kio-plugins or kdebase-kio-plugins to 
dependencies on both; simple, and should prevent user error. (Closes: 
#327821)

* Make kaddressbook suggest kdebase-kio-plugins for LDAP support.
(Closes: #337527)

* Add Spanish debconf translation. (Closes: #383360)

* Move libemailfunctions/idmapper.h from kdepim-dev to libkcal2-dev. 
kdepim-dev depends on libkcal2-dev, so this shouldn't cause any 
problems. Replaces have been added. (Closes: #342452)

* Fix small bug in kmail_clamav.sh script. (Closes: #354185)

* Install ktnef MIME entries to /etc/mailcap. (Closes: #316373)

Attachment: pgpIyEBdekR4U.pgp
Description: PGP signature


--- End Message ---

Reply to: