[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#701308: pam-unix2 no longer build with latest glibc headers

Hi Petter,

On Mon, Jul 01, Petter Reinholdtsen wrote:

> Hi, Thorsten.
> I was looking at a build failure for libpam-unix2 in the latest Debian
> build environment, and discovered that the problem is that it is using a
> set of lock macros no longer provided by libc.  I fetched the latest
> version from <URL: ftp://ftp.suse.com/pub/people/kukuk/pam/pam_unix2/ >.

Didn't know that this directory exists again ...

> This is the build error with version 2.6:
> Perhaps time to make a new release?

There were some newer releases, all can be found in the openSUSE

But yes, the lock-problem is only solved with a patch, too.


Thorsten Kukuk, Project Manager/Release Manager SLES
SUSE LINUX Products GmbH, Maxfeldstr. 5, D-90409 Nuernberg
GF: Jeff Hawn, Jennifer Guild, Felix Imendörffer, HRB 16746 (AG Nürnberg)

Reply to: