[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#485799: marked as done (NMU diff for FTGL transition)

Your message dated Sat, 13 Apr 2013 12:02:48 +0000
with message-id <E1UQzAO-0003zS-Na@franck.debian.org>
and subject line Bug#485799: fixed in lightspeed 1.2a-9
has caused the Debian Bug report #485799,
regarding NMU diff for FTGL transition
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

485799: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=485799
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: lightspeed
Version: 1.2a-7.1
Severity: important
Tags: patch


   attached is a patch for lightspeed to make it build with the forthcoming
version of FTGL (currently in experimental). Since your package will still
build fine after ftgl 2.1.3 is uploaded to unstable, there is no need to
synchronise our actions: you can upload a fixed package whenever you wish.

-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux (SMP w/2 CPU cores; PREEMPT)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages lightspeed depends on:
ii  libatk1.0-0            1.22.0-1          The ATK accessibility toolkit
ii  libc6                  2.7-12            GNU C Library: Shared libraries
ii  libcairo2              1.6.4-4           The Cairo 2D vector graphics libra
ii  libfontconfig1         2.6.0-1           generic font configuration library
ii  libfreetype6           2.3.5-1+b2        FreeType 2 font engine, shared lib
ii  libgcc1                1:4.3.0-5         GCC support library
ii  libgl1-mesa-glx [libgl 7.0.3-1           A free implementation of the OpenG
ii  libglib2.0-0           2.16.3-2          The GLib library of C routines
ii  libglu1-mesa [libglu1] 7.0.3-1           The OpenGL utility library (GLU)
ii  libgtk2.0-0            2.12.10-2         The GTK+ graphical user interface 
ii  libgtkglext1           1.2.0-1           OpenGL Extension to GTK+ (shared l
ii  libice6                2:1.0.4-1         X11 Inter-Client Exchange library
ii  libpango1.0-0          1.20.2-2          Layout and rendering of internatio
ii  libpng12-0             1.2.27-1          PNG library - runtime
ii  libsm6                 2:1.0.3-1+b1      X11 Session Management library
ii  libstdc++6             4.3.0-5           The GNU Standard C++ Library v3
ii  libtiff4               3.8.2-8           Tag Image File Format (TIFF) libra
ii  libx11-6               2:1.0.3-7         X11 client-side library
ii  libxcursor1            1:1.1.9-1         X cursor management library
ii  libxext6               2:1.0.4-1         X11 miscellaneous extension librar
ii  libxfixes3             1:4.0.3-2         X11 miscellaneous 'fixes' extensio
ii  libxi6                 2:1.1.3-1         X11 Input extension library
ii  libxinerama1           2:1.0.3-2         X11 Xinerama extension library
ii  libxmu6                2:1.0.4-1         X11 miscellaneous utility library
ii  libxrandr2             2:1.2.2-2         X11 RandR extension library
ii  libxrender1            1:0.9.4-1         X Rendering Extension client libra
ii  libxt6                 1:1.0.5-3         X11 toolkit intrinsics library
ii  zlib1g                 1: compression library - runtime

lightspeed recommends no packages.
diff -puriN lightspeed-1.2a.sid/debian/changelog lightspeed-1.2a/debian/changelog
--- lightspeed-1.2a.sid/debian/changelog	2008-06-11 13:41:33.000000000 +0000
+++ lightspeed-1.2a/debian/changelog	2008-06-11 13:42:31.000000000 +0000
@@ -1,3 +1,11 @@
+lightspeed (1.2a-7.1) experimental; urgency=low
+  * Non-maintainer upload.
+  * Build-depend on libftgl-dev in order to use the shared version of the
+    library.
+ -- Sam Hocevar (Debian packages) <sam+deb@zoy.org>  Wed, 11 Jun 2008 13:42:12 +0000
 lightspeed (1.2a-7) unstable; urgency=high
   * Workaround for FcFini problem in fontconfig package. Commenting out
diff -puriN lightspeed-1.2a.sid/debian/control lightspeed-1.2a/debian/control
--- lightspeed-1.2a.sid/debian/control	2008-06-11 13:41:33.000000000 +0000
+++ lightspeed-1.2a/debian/control	2008-06-11 13:42:04.000000000 +0000
@@ -3,7 +3,7 @@ Section: misc
 Priority: optional
 Maintainer: Ola Lundqvist <opal@debian.org>
-Build-Depends: debhelper (>> 4.0.0), libgtkglext1-dev, libgtk2.0-dev, libpng12-dev, libtiff4-dev, libxi-dev, zlib1g-dev, libgl1-mesa-dev | libgl-dev, ftgl-dev, libfontconfig1-dev
+Build-Depends: debhelper (>> 4.0.0), libgtkglext1-dev, libgtk2.0-dev, libpng12-dev, libtiff4-dev, libxi-dev, zlib1g-dev, libgl1-mesa-dev | libgl-dev, libftgl-dev, libfontconfig1-dev
 Package: lightspeed
 Architecture: any

--- End Message ---
--- Begin Message ---
Source: lightspeed
Source-Version: 1.2a-9

We believe that the bug you reported is fixed in the latest version of
lightspeed, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 485799@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Boris Pek <tehnick-8@mail.ru> (supplier of updated lightspeed package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA256

Format: 1.8
Date: Tue, 20 Nov 2012 00:36:27 +0200
Source: lightspeed
Binary: lightspeed
Architecture: source amd64
Version: 1.2a-9
Distribution: unstable
Urgency: low
Maintainer: Debian QA Group <packages@qa.debian.org>
Changed-By: Boris Pek <tehnick-8@mail.ru>
 lightspeed - Shows how objects moving at relativistic speeds look like
Closes: 449901 461272 485799 649787 662418
 lightspeed (1.2a-9) unstable; urgency=low
   * QA upload.
   * Bumped Standards-Version to 3.9.3 (was
   * Bumped debhelper version to 9 (was 4.0.0); updated debian/compat.
   * Added file debian/source/format: format 1.0 is still used in this package.
   * Added files debian/docs and debian/manpages to simplify debian/rules.
   * Deleted files config/config.guess and config/config.sub.
     Files from the package autotools-dev are used instead.
   * Rewritten debian/rules:
     - now dh is used instead of direct dh_* commands
     - added --as-needed option to LDFLAGS
     - added section get-orig-source (uscan is used)
     - used symlinks for config/config.guess and config/config.sub
     - fixed lintian warnings:
       + hardening-no-relro
       + hardening-no-fortify-functions
       + debian-rules-ignores-make-clean-error
       + debian-rules-missing-recommended-target build-arch
       + debian-rules-missing-recommended-target build-indep
       + dh-clean-k-is-deprecated
   * Updated debian/control:
     - added Homepage field
     - added Vcs-* fields (Git repo in collab-maint is available now)
     - changed build dependency from libpng12-dev to libpng-dev (Closes: #662418)
     - changed build dependency from ftgl-dev to libftgl-dev (Closes: #485799)
     - changed build dependency from libtiff4-dev to libtiff-dev
       (preparation for switching to libtiff5 in Debian Jessie)
     - added build dependency from autotools-dev
     - added ${misc:Depends} to list of dependencies
     - lightspeed now suggests recommended font ttf-dejavu instead of font
       ttf-bitstream-vera which is going to be removed from the repository
       (Closes: #461272)
   * Updated debian/copyright: fixed lintian warning
   * Updated debian/watch: fixed lintian warning
     debian-watch-file-should-use-sf-redirector. (Closes: #449901)
   * Patched file src/snapshot.c. [Thanks to Nobuhiro Iwamatsu] (Closes: #649787)
     But build with libpng version 1.5.10 now impossible because
     `pkg-config --cflags gtk+-2.0` returns error:
     "Package 'libpng12', required by 'GdkPixbuf', not found"
 78da7d678022f8c6c8811120177e8b50e55f4cb0 1988 lightspeed_1.2a-9.dsc
 767ac436fa8b93cf8937045e336b555d91e3bdef 163764 lightspeed_1.2a.orig.tar.gz
 86ce6119f516458e81ec49ac4bb032e5c1794101 358929 lightspeed_1.2a-9.diff.gz
 eac98bdc7d54f7c535d83d85a2e6e20dfd4de4e3 111694 lightspeed_1.2a-9_amd64.deb
 63526e16d0102a6ac46a61806249dce339c1462a8cd3b0e085cb76362bb5c146 1988 lightspeed_1.2a-9.dsc
 a8752acce625436b699b4d3c1ab479bd4116673784f17e527a3e37374abc4f4b 163764 lightspeed_1.2a.orig.tar.gz
 daa0ee8cd778ebb6e1230adb64fa58bfdbd6d3700f1eab21b427db8ff506350e 358929 lightspeed_1.2a-9.diff.gz
 15bdd185b3dc4e01414d0d1701506ea73583bd1b029e0a154ceb911a447531a9 111694 lightspeed_1.2a-9_amd64.deb
 51f3d24f1696f704b4631b08106f618e 1988 misc optional lightspeed_1.2a-9.dsc
 d6162f8b200db8ebfade791a71a439c0 163764 misc optional lightspeed_1.2a.orig.tar.gz
 2e2f6a8e785a6eac909c4d67ca4ba390 358929 misc optional lightspeed_1.2a-9.diff.gz
 6e59679ef68c8dbb754975122fe4afa8 111694 misc optional lightspeed_1.2a-9_amd64.deb

Version: GnuPG v1.4.12 (GNU/Linux)


--- End Message ---

Reply to: