[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#694022: marked as done (Incorrect LSB header, Should-Start contains obsolete hal)

Your message dated Fri, 15 Feb 2013 12:02:40 +0000
with message-id <E1U6K00-0006Om-S0@franck.debian.org>
and subject line Bug#694022: fixed in wdm 1.28-14~exp1
has caused the Debian Bug report #694022,
regarding Incorrect LSB header, Should-Start contains obsolete hal
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

694022: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=694022
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: wdm
Version: 1.28-13
Severity: normal
User: pkg-utopia-maintainers@lists.alioth.debian.org
Usertags: halectomy


HAL has been deprecated and declared dead upstream so we want to
get rid of it in Debian [1].

The wdm sysv init script contains in its LSB header

# Should-Start:      xfs $named slapd console-screen kbd acpid dbus hal network-manager
# Should-Stop:       xfs $named slapd console-screen kbd acpid dbus hal network-manager

Afaics wdm does not actually need or use hal so this dependency should
be dropped. Besides, hal is started via D-Bus activation nowadays
making this dependency obsolete.


[1] http://wiki.debian.org/HALRemoval

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (200, 'experimental')
Architecture: amd64 (x86_64)
Foreign Architectures: i386

Kernel: Linux 3.5-trunk-amd64 (SMP w/4 CPU cores)
Locale: LANG=de_DE.utf8, LC_CTYPE=de_DE.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

--- End Message ---
--- Begin Message ---
Source: wdm
Source-Version: 1.28-14~exp1

We believe that the bug you reported is fixed in the latest version of
wdm, which is due to be installed in the Debian FTP archive.

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 694022@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Agustin Martin Domingo <agmartin@debian.org> (supplier of updated wdm package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.8
Date: Fri, 15 Feb 2013 12:03:55 +0100
Source: wdm
Binary: wdm
Architecture: source i386
Version: 1.28-14~exp1
Distribution: experimental
Urgency: low
Maintainer: Debian QA Group <packages@qa.debian.org>
Changed-By: Agustin Martin Domingo <agmartin@debian.org>
 wdm        - WINGs Display Manager - an xdm replacement with a WindowMaker loo
Closes: 694022 700422
 wdm (1.28-14~exp1) experimental; urgency=low
   * QA upload.
   * wdm.init: Remove obsolete "hal" from Should-Start in incorrect LSB
     header (Closes: #694022).
   * 08_do_not_use_dev_mem.patch: Use /dev/urandom instead of
     /dev/mem. Thanks Borislav Petkov (Closes: #700422).
   * Add watch file, in case upstream resumes work in this package.
     Thanks Bart Martens for it.
   * debian/control: Bump Standards-Version. No changes required.
 11833e68a32a83d7d28be8ffddfad45ae7f822a1 1464 wdm_1.28-14~exp1.dsc
 4b1971d2a9abd2b38a2f13c67176bd5e68d99d0d 70320 wdm_1.28-14~exp1.debian.tar.gz
 8faa8aef368237126f19d8f08e4efb74c6805064 338366 wdm_1.28-14~exp1_i386.deb
 f41f79bd59d407ce7098d0380b5679379638ec10a1532a9a8ef1b585676c8b43 1464 wdm_1.28-14~exp1.dsc
 bdc028c8bdd589c0d61f6231792d43e1d095463d1995705d7240da451177ad24 70320 wdm_1.28-14~exp1.debian.tar.gz
 22f5d4ef476160bf7551c6740e240727b765107b2fef0a51d257c2c70f457506 338366 wdm_1.28-14~exp1_i386.deb
 5f0e46488a6dcf722f4e49194d49d8b4 1464 x11 optional wdm_1.28-14~exp1.dsc
 8fa7db38e4e6df9d9b074effc630c847 70320 x11 optional wdm_1.28-14~exp1.debian.tar.gz
 031b6fa8030d0c2ec4bcd8bccac4dcde 338366 x11 optional wdm_1.28-14~exp1_i386.deb

Version: GnuPG v1.4.12 (GNU/Linux)


--- End Message ---

Reply to: