[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#639556: smart-notifier: must not restart dbus on install/upgrade

Package: smart-notifier
Version: 0.28-3
Severity: grave
Justification: causes non-serious data loss


Installing the package will result in restart of dbus:
| Setting up smart-notifier (0.28-3) ...
| Stopping system message bus: dbus.
| Starting system message bus: dbus.

This lead to a crash of X session (or a restart if systemd is the init
process). Thus, any file not yet saved is lost.

The package must not restart dbus, but reload it.


-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (500, 'unstable'), (500, 'testing'), (100, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.0.0-1-amd64 (SMP w/2 CPU cores)
Locale: LANG=de_DE.utf8, LC_CTYPE=de_DE.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages smart-notifier depends on:
ii  dbus                      1.4.14-1       simple interprocess messaging syst
ii  python                    2.6.7-3        interactive high-level object-orie
ii  python-dbus               0.84.0-2       simple interprocess messaging syst
ii  python-glade2             2.24.0-2       GTK+ bindings: Glade support
ii  python-gtk2               2.24.0-2       Python bindings for the GTK+ widge
ii  smartmontools             5.41+svn3365-1 control and monitor storage system

smart-notifier recommends no packages.

smart-notifier suggests no packages.

-- no debconf information

Reply to: