[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#635950: auto-apt: Preloaded library doesn't match arch

Package: auto-apt
Version: 0.3.22
Severity: important

When used to run a i386 binary in a amd64 system it fails with message:
ERROR: ld.so: object '/lib/auto-apt.so' from LD_PRELOAD cannot be preloaded:

The library that is trying to preload is 64bits while the executable is 32bits.

-- System Information:
Debian Release: wheezy/sid
  APT prefers unstable
  APT policy: (990, 'unstable'), (500, 'testing'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 3.0.0-1-amd64 (SMP w/1 CPU core)
Locale: LANG=es_ES.utf8, LC_CTYPE=es_ES.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages auto-apt depends on:
ii libc6 2.13-11 Embedded GNU C Library: Shared lib

Versions of packages auto-apt recommends:
ii  apt                    Advanced front-end for dpkg
ii devscripts 2.11.0 scripts to make the life of a Debi ii dpkg-dev Debian package development tools ii perl 5.12.4-2 Larry Wall's Practical Extraction ii sudo 1.7.4p6-1 Provide limited super user privile
ii  wget                          1.12-5     retrieves files from the web

Versions of packages auto-apt suggests:
ii build-essential 11.5 Informational list of build-essent ii gnome-terminal [x-terminal-em 3.0.1-1 GNOME terminal emulator applicatio
pn  libgtk-perl <none>     (no description available)
ii rxvt [x-terminal-emulator] 1:2.6.4-14 VT102 terminal emulator for the X
ii  xterm [x-terminal-emulator]   271-1      X terminal emulator
ii xvt [x-terminal-emulator] 2.1-20 X terminal-emulator similar to xte

-- no debconf information


Reply to: