[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#634732: marked as done (wdm: debian/control uses hardcoded list of non-Linux architectures)

Your message dated Tue, 26 Jul 2011 13:20:24 +0000
with message-id <E1QlhYe-0003Dr-Mh@franck.debian.org>
and subject line Bug#634732: fixed in wdm 1.28-8
has caused the Debian Bug report #634732,
regarding wdm: debian/control uses hardcoded list of non-Linux architectures
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

634732: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=634732
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: wdm
Severity: wishlist
User: debian-devel@lists.debian.org
Usertags: linux-any

The debian/control file in wdm uses a negated list of architectures
to specify a package relationship (most likely Build-Depends) on a
Linux-specific package.  I.e. something like:

 Build-Depends: libfoo-dev [!kfreebsd-i386 !kfreebsd-amd64 !hurd-i386]

This is problematic because it will fail for any future kfreebsd-* or hurd-*
architecture (like the upcoming kfreebsd-mipsel port).  The correct way
would be to use dpkg architecture wildcards, e.g.:

 Build-Depends: libfoo-dev [linux-any]

Please consider making this adjustment to make life easier for future
porting efforts.


--- End Message ---
--- Begin Message ---
Source: wdm
Source-Version: 1.28-8

We believe that the bug you reported is fixed in the latest version of
wdm, which is due to be installed in the Debian FTP archive:

  to main/w/wdm/wdm_1.28-8.debian.tar.gz
  to main/w/wdm/wdm_1.28-8.dsc
  to main/w/wdm/wdm_1.28-8_i386.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 634732@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Agustin Martin Domingo <agmartin@debian.org> (supplier of updated wdm package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.8
Date: Tue, 26 Jul 2011 11:03:55 +0200
Source: wdm
Binary: wdm
Architecture: source i386
Version: 1.28-8
Distribution: unstable
Urgency: low
Maintainer: Debian QA Group <packages@qa.debian.org>
Changed-By: Agustin Martin Domingo <agmartin@debian.org>
 wdm        - WINGs Display Manager - an xdm replacement with a WindowMaker loo
Closes: 634732
 wdm (1.28-8) unstable; urgency=low
   * QA upload.
   * Use individual quilt patches instead of monolithic 3.0 format
     single patch. Fix lintian format-3.0-but-debian-changes-patch.
   * wdm.preinst: Add debhelper token.
   * debian/control:
     - Bump Standards-Version. No changes required.
     - Use dpkg architecture wildcard linux-any instead of hardcoded
       negated list of non-Linux architectures  (Closes: #634732).
   * debian/rules:
     - Fix lintian debian-rules-missing-recommended-target build-{arch,indep}
 ef5d152cb24c28526b1632702fed73d5aca2b9c8 1382 wdm_1.28-8.dsc
 a35aeefaca4ec493f110ba0931efab715f1099aa 69570 wdm_1.28-8.debian.tar.gz
 c24906b61ba42dfa6d92b6318d3bbf1d9d4fa365 425678 wdm_1.28-8_i386.deb
 0d44a78a5c1b1c9cc040d7dbe901de1b817f4e719470c4efdd942dceb02d62c1 1382 wdm_1.28-8.dsc
 eec452846c438d5dcad8c9138fb0676e8e2ffc5c7e60612de82bb19e4365d985 69570 wdm_1.28-8.debian.tar.gz
 78ebbbaa623002fcd66387f824b0b339cc54e19e23cc7848f3282de216f9b3c5 425678 wdm_1.28-8_i386.deb
 c8a21e9ca0a71430b6813d444dacabbf 1382 x11 optional wdm_1.28-8.dsc
 4e1a42139cd1a9be9dec2a696326032c 69570 x11 optional wdm_1.28-8.debian.tar.gz
 1b1ea05da25b616c21458347238203a3 425678 x11 optional wdm_1.28-8_i386.deb

Version: GnuPG v1.4.11 (GNU/Linux)


--- End Message ---

Reply to: