[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#622435: marked as done (opencryptoki: Getting rid of unneeded *.la / emptying dependency_libs)

Your message dated Fri, 03 Jun 2011 11:29:33 +0000
with message-id <E1QSSZJ-0002Fo-0R@franck.debian.org>
and subject line Bug#622435: fixed in opencryptoki 2.2.8+dfsg-5
has caused the Debian Bug report #622435,
regarding opencryptoki: Getting rid of unneeded *.la / emptying dependency_libs
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

622435: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=622435
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: opencryptoki
Version: 2.2.8+dfsg-4
Severity: normal
User: codehelp@debian.org
Usertags: la-file-removal

To finish an old release goal from Squeeze, to comply with Policy
10.2 and to ease the introduction of MultiArch, I'm filing bugs
against packages which contain .la files which can be either removed
or stripped of the dependency_libs variable.




Data has been obtained from the output of an automated script:


The output is best read in conjunction with the criteria from this
post to debian-devel:


To generate the list of packages, I've used:

grep -v depended-on current.txt |cut -d: -f1

The data is regularly updated but please accept my apologies if you
have made an upload which changes the situation since the data was

opencryptoki appears in this list as a source package because one or
more of the binary packages (usually -dev packages) contain .la

In most cases, the .la file(s) can simply be removed as the process
behind this MBF has already identified that there are no further
dependencies using the .la file. In the unusual case that your
package uses libltdl directly, it is still necessary to empty the
dependency_libs part of all .la files remaining in the package. Once
opencryptoki is fixed, the process will repeat and other packages
which you maintain may need to be fixed in turn. It is important that
packages are fixed in sequence to avoid FTBFS bugs.

If you believe that your package needs both the .la file and the
dependency_libs settings, please raise this on debian-devel for

Neil Williams

--- End Message ---
--- Begin Message ---
Source: opencryptoki
Source-Version: 2.2.8+dfsg-5

We believe that the bug you reported is fixed in the latest version of
opencryptoki, which is due to be installed in the Debian FTP archive:

  to main/o/opencryptoki/libopencryptoki-dev_2.2.8+dfsg-5_amd64.deb
  to main/o/opencryptoki/libopencryptoki0_2.2.8+dfsg-5_amd64.deb
  to main/o/opencryptoki/opencryptoki-dbg_2.2.8+dfsg-5_amd64.deb
  to main/o/opencryptoki/opencryptoki_2.2.8+dfsg-5.debian.tar.gz
  to main/o/opencryptoki/opencryptoki_2.2.8+dfsg-5.dsc
  to main/o/opencryptoki/opencryptoki_2.2.8+dfsg-5_amd64.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 622435@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Alessio Treglia <alessio@debian.org> (supplier of updated opencryptoki package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.8
Date: Fri, 03 Jun 2011 12:23:26 +0200
Source: opencryptoki
Binary: opencryptoki opencryptoki-dbg libopencryptoki0 libopencryptoki-dev
Architecture: source amd64
Version: 2.2.8+dfsg-5
Distribution: unstable
Urgency: low
Maintainer: Debian QA Group <packages@qa.debian.org>
Changed-By: Alessio Treglia <alessio@debian.org>
 libopencryptoki-dev - PKCS#11 implementation for Linux (development)
 libopencryptoki0 - PKCS#11 implementation for Linux (library)
 opencryptoki - PKCS#11 implementation for Linux (daemon)
 opencryptoki-dbg - PKCS#11 implementation for Linux (debug)
Closes: 622435
 opencryptoki (2.2.8+dfsg-5) unstable; urgency=low
   * QA upload.
   * Get rid of unneeded *.la files (Closes: #622435).
   * Switch to 3.0 (quilt) format.
   * Bump debhelper build-dep to (>= 7.0.50~).
   * Use DH's autotools_dev addon to update config.{guess,sub} files rather
     than copy&and restore them in debian/rules.
   * Fix lintian "binary-control-field-duplicates-source field section in
     package opencryptoki" warning.
   * Bump Standards.
 f7036148669dbdff4dd832c3a38d7564a98db6ae 1194 opencryptoki_2.2.8+dfsg-5.dsc
 c3ff12e314b35892d7db622e76192e2fb5e0ccdb 14020 opencryptoki_2.2.8+dfsg-5.debian.tar.gz
 d258b066f43722934c5933ce294c9ef755d46bab 55518 opencryptoki_2.2.8+dfsg-5_amd64.deb
 8799b5b07cde89b49d374003a2e3299af8351165 494056 opencryptoki-dbg_2.2.8+dfsg-5_amd64.deb
 8c9c9b165fc3d09f86d59f2d9d0c905e2b7f4636 256764 libopencryptoki0_2.2.8+dfsg-5_amd64.deb
 22fa40be1937945ee14839aff23a57472bc7bb16 29364 libopencryptoki-dev_2.2.8+dfsg-5_amd64.deb
 281bbf739122b3d940d173c8878f1b921bff9a1f50eb6d4a5c0a0cd47a5cd796 1194 opencryptoki_2.2.8+dfsg-5.dsc
 9aa06559044467664ee878c6f212c53e16c44646322b49363cf7f721c7851e3e 14020 opencryptoki_2.2.8+dfsg-5.debian.tar.gz
 5d107ec1aa6590b562c385c9a653b0638c2d3cd32595ab85e46477442b176667 55518 opencryptoki_2.2.8+dfsg-5_amd64.deb
 b37dcda9e9aaca738550b7d84b263f829fe22a8d0e72b3dd760f8f2f7a598d2f 494056 opencryptoki-dbg_2.2.8+dfsg-5_amd64.deb
 4ba680b8026a3103eefe07f212ed5a1b05ff884b257ca018c85e469c8727225d 256764 libopencryptoki0_2.2.8+dfsg-5_amd64.deb
 16237d0a672d561e4fc406e7cb1d59334208e8ea6decbc53511dfe201edd6733 29364 libopencryptoki-dev_2.2.8+dfsg-5_amd64.deb
 d2bb06a61a1432249d8c809e92d51fad 1194 admin optional opencryptoki_2.2.8+dfsg-5.dsc
 f58fd12df259ff30e14bc5fa3548e828 14020 admin optional opencryptoki_2.2.8+dfsg-5.debian.tar.gz
 1c0fb7a85cd617cd1aa55c9d0198983a 55518 admin optional opencryptoki_2.2.8+dfsg-5_amd64.deb
 889e43903dfa19b943c27f5cb934c80d 494056 debug extra opencryptoki-dbg_2.2.8+dfsg-5_amd64.deb
 88142462b8382c8a710a9d87a558fb85 256764 libs optional libopencryptoki0_2.2.8+dfsg-5_amd64.deb
 8e0fab4f5f927293fe762ebb4e48f6ee 29364 libdevel optional libopencryptoki-dev_2.2.8+dfsg-5_amd64.deb

Version: GnuPG v1.4.11 (GNU/Linux)


--- End Message ---

Reply to: